Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Everything was working fine in Ubuntu 11.10, but today suddenly the first option from GRUB menu, which normally boots Ubuntu stopped working and i am left with a pink-color-screen only.

If i select and boot from the options of previous Linux version, then it works completely fine. I am not familiar with command line things, but if somebody could give me all the commands necessary, or any other possible solution, it would be very helpful to me.

I have a dual-boot-system with Windows 7

share|improve this question
    
if any of these answers "answered" your question please accept one of them :) –  blade19899 Jul 11 '12 at 16:04
add comment

2 Answers

One of the first steps is to boot Ubuntu in recovery mode:

Basically, you select the

Ubuntu, kernel 2.6.xx.xx-generic (recovery mode)

option in the GRUB menu. Choose the recovery mode of the kernel that is not working for you (I assume tha t is the latest, so the one with the highest kernel number combination.) You should now get some options of which the option "Drop to root shell prompt gives you the chance to make some repairs on the command line.

For analysis you can now look at your log files:

cat /var/log/syslog

and

cat /var/log/dmesg

this might help. You could attach them to your question for others to see.

You can also try to see what happens if you start the X display manager (lightdm)

lightdm

[GUESSING] One possibility is that, you use a fglrx or nvidia driver that needs to be recompiled (but again i am just GUESSING here, i know nothing of your setup).

Check if you have a /etc/X11/xorg.conf (is normally NOT there). If it is present, rename it :

mv /etc/X11/xorg.conf /etc/X11/xorg.conf.mypersonalbackup

and try again.

You might experience loss in video quality until you recompiled/reinstalled your video driver.

share|improve this answer
add comment

boot from the option of previous Linux version
open gnome-terminal typ in

sudo update-grub
share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.