Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I am having problems with installation with everything in the software center.

Traceback (most recent call last):
  File "/usr/lib/python2.7/dist-packages/aptdaemon/", line 968, in simulate
    trans.unauthenticated = self._simulate_helper(trans)
  File "/usr/lib/python2.7/dist-packages/aptdaemon/", line 1092, in _simulate_helper
    return depends, self._cache.required_download, \
  File "/usr/lib/python2.7/dist-packages/apt/", line 235, in required_download
    pm.get_archives(fetcher, self._list, self._records)
SystemError: E:I wasn't able to locate a file for the sun-java6-jre package. This might mean you need to manually fix this package.


share|improve this question
I solved the problem – Nyx Mar 4 '12 at 2:00
Marv, if you solved the problem, please do add it as an answer so we can upvote the answer and mark this question as solved. Thanks! – jokerdino Mar 4 '12 at 12:34

Here is what I think you should do:

sudo apt-get --configure -a 
sudo apt-get update 
sudo apt-get upgrade 

I'm not sure but I think this might help...

share|improve this answer
I tried that. No worries. I solved it. – Nyx Mar 4 '12 at 1:59
@Marv if Nikolas helped you. It would be nice if you honour it otherwise please tell us how you solved this problem maybe it could help other people with similar problems. :-) – tvn Mar 4 '12 at 2:22
@tvn 2 more hours. =D – Nyx Mar 4 '12 at 7:08
up vote 0 down vote accepted

I used

dpkg --remove --force-remove sun-java6-bin

The problem was caused by an incomplete installation of JDK6

For anyone having this problem, I recommend installing Synaptic Package Manager after fixing this to avoid any problems like this in the future.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.