Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

When working on the Calc (spreadsheet) many time the screen goes grey and CPU cycle shoots up to 100% for a very long time and the app is not responsive. Also slows down other open apps etc due to CPU being at 100%. Is there anyway this can be avoided?

The file size doesn't really matter as it happens with having only one sheet with simple data as well as file with several sheets and calculations. Running Ubuntu 11.10 on a Dell Inspiron 1300 with 2 GB ram and Intel Celeron 1.5 GHz CPU. Long time sometimes over 2 mins. I haven't used Top but can give it a try if I knew what it is

  • Changing the Graphic cache user for liberoffice did not really change anything.
share|improve this question
1  
Insufficient data - how big is the file? Is the sheet calculation-intensive? Are you using a low-end CPU or low on RAM? How long is a 'very long' time? Are you running macros or scripts on the sheet? What other applications do you have open at the time? Have you used 'top' to check for other resource hogs? –  user535733 Mar 3 '12 at 23:11
    
The file size doesn't really matter as it happens with having only one sheet with simple data as well as file with several sheets and calculations. Running Ubuntu 11.10 on a Dell Inspiron 1300 with 2 GB ram and Intel Celeron 1.5 GHz CPU. Long time sometimes over 2 mins. I haven't used Top but can give it a try if I knew what it is :-) –  user35021 Mar 6 '12 at 2:43
    
Could it be that there's a formula that's faulty? Is there a formula common to all your problematic sheets or files? And you can use the man command to see what top does. You would type man top in a terminal. Top is present by default on your Ubuntu. –  user25656 Mar 8 '12 at 3:30

2 Answers 2

Open any LibreOffice application. In the Tool-bar under "Tools" use the drop-down and open "options" look for "memory". This setting as well as others will help limit CPU cycles and decrease lag time. enter image description here

share|improve this answer
    
I'm just wondering whether reducing the Use for LibreOffice in Graphics cache will help or have the opposite effect. I've sometimes encountered problems similar to what OP has reported, but then mostly with Writer and rarely with Calc. The settings are as shown in the graphic above. The OS is 11.10 (Unity 3D) on a Dell Inspiron 1545 laptop with 4 GB RAM. I don't do too many things at one time ... maybe listen to music (Totem), have a few tabs open in Firefox and LibreOffice. My non-technical opinion is that there are some situations that cause LibreOffice to go crazy. –  user25656 Mar 4 '12 at 4:59
    
Changing the Graphic cache user for liberoffice did not really change anything. –  user35021 Mar 6 '12 at 5:48

I've found workaround: go to "Tools/Options/View" and uncheck "Graphics output: Anti-aliasing". Works for me. I've posted bug report here. Maybe it's your case too.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.