Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

My apt-get is currently complaining about unmet dependencies (and refuses to do anything until I fix them):

Reading package lists... Done
Building dependency tree       
Reading state information... Done
You might want to run 'apt-get -f install' to correct these.
The following packages have unmet dependencies:
 libavcodec53 : Depends: libva1 (> 1.0.12~) but 0.31.1-1+sds4 is installed
 libva-dev : Depends: libva1 (>= 1.0.12) but 0.31.1-1+sds4 is installed
 libva-glx1 : Depends: libva1 (> 1.0.12~) but 0.31.1-1+sds4 is installed
 libva-tpi1 : Depends: libva1 (> 1.0.12~) but 0.31.1-1+sds4 is installed
 vainfo : Depends: libva1 (> 1.0.12~) but 0.31.1-1+sds4 is installed
E: Unmet dependencies. Try using -f.

The thing is, I absolutely need that specific version of libva1. Anything newer doesn't work with mplayer-vaapi. The purported unmet dependencies do not seem to have any negative effects on my system (other than breaking APT), so is there any way I can make apt-get ignore them and just do what it's told?

share|improve this question
    
Good question. It tells you to use -f, have you tried that? If you have manually downloaded a package you can edit it's control file to remove dependencies you can't meet, but that's not exactly what you need in that case (though related). –  Rafał Cieślak Mar 3 '12 at 22:49
    
@rafalcieslak Yes, running 'sudo apt-get -f install' fixes the dependencies, but breaks mplayer. –  bessman Mar 3 '12 at 23:22

1 Answer 1

up vote 2 down vote accepted

If you have a particular application you do not want upgraded then "pin" it or "freeze" it using synaptic.

Highlight your selection > Go to Package > scroll down to "Lock Version" and click enter image description here

share|improve this answer
    
Thanks! Pinning libva1 didn't fix the broken dependencies, but through synaptic I was able to remove the five broken packages, which solved the problem! –  bessman Mar 4 '12 at 0:09
    
Good, glad to help out –  Ringtail Mar 4 '12 at 0:10

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.