Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

In my System I have a 120GB SSD and a 1TB HDD. I have Windows 7 installed on the SSD and I partitioned the HDD in 2 Partitions on for Windows programs and files. And one for Ubuntu.

But after I installed Ubuntu beside Windows 7, Grub hasn't recognized my Windows 7 install on SSD.

What can I do now to be able to access/boot Windows 7 again?

share|improve this question
add comment

3 Answers 3

When you installed to the HDD the Ubuntu bootloader was also most likely installed to that same drive. Since your BIOS 'boot order' probably lists the SSD above the HDD, your bootloader (GRUB) isn't part of the boot process. It's there and set correctly, but it's just being skipped when your system checks the Windows drive and finds a boot partition there.

You can either try booting from a live CD/USB and 'repair GRUB' by installing it to the SSD, or change the boot order of the drives in the BIOS.

I would try changing the BIOS setting first, that's the easiest.

EDIT Sorry I just realized I read the question wrong. You can probably still fix things by following the 'repair GRUB' link though. Once you get the Windows entry in GRUB, here is a post explaining how to make it default.

share|improve this answer
add comment

Which one is your master drive? HDD or SSD? If SSD is the Master drive than you can use EasyBCD (from NeoWin for Windows 7) to add a linux entry so you can use Windows Boot Menu for accessing the Ubuntu easy way!

share|improve this answer
add comment

If you are unsure on how-to's for the methods above, and got plenty of time, you can try to reinstall Ubuntu on your HDD, but using the Manual Partition option, (or as called "Something Else" on the setup), then, on the option to "Select Drive for the bootloader installation, set it on the SSD. I think this should work. Good luck! ;)

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.