Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have Ubuntu 11.10. I have an English keyboard and have set the keyboard layout to English (UK) in the System settings -> Keyboard Layout. It is the only layout listed.

Recently my keyboard has gone to US layout. I don't know why and I cannot change it back.
The " and @ are in the wrong place.

I've typed man loadkeys and the documentation tells me that the default keymap is probably in a file called either in /usr/share/keymaps or in /usr/src/linux/drivers/char. I can find neither of these directories. Can anybody tell me where the file is in my distribution, or if it is there at all?

share|improve this question

I had the same issue. Even though English (UK) was selected for everything it was still using a US layout.

For some reason adding English (US) keyboard layout below the English (UK) entry in System Settings -> Region & Language -> Layouts made everything work.

share|improve this answer
This solved it for me too on Ubuntu 13! I just had English (UK) selected and the character mapping of my british keyboard was totally screwed, even if when I clicked on the Keyboard Layout it showed the right one. I added the English (US) layout, which I don't need, but kept English (UK) layout selected and it immediately solved the issue! – jbx Dec 13 '13 at 10:28
Similar problem in 14.04 after a fresh upgrade, and this fixed it. – E.P. Jun 25 '14 at 10:39

I have this problem in 14.04 According to everything that I look at I'm using En1 (UK) but it is actually En2 (US). eg

/etc/default/keyboard says "gb"

It switches back regularly. It says UK but it isn't. The keyboard layout chart shows things as they should be, but they aren't.

Workaround #1: If I switch from En1 to En2 & back it corrects itself until the next time I reboot.

It looks like we're dealing with this bug:

A workaround involving customising ibus-setup from this page did not work for me.

Removing Ibus seems to work. Hooray! Well it takes most of the Unity System Settings with it. Not good :(

Workaround #2: Look in your home directory & press control h to see hidden files. Open ~/.config/ibus/bus & delete the file therein. Then reboot.

This works until the next time that you do an upgrade, then you need to do it again, unless, after that first reboot, you change the permissions to make the file read-only.

share|improve this answer
Still with us, with… – Rmano May 21 '14 at 17:39
Workaround #2 didn't work for me, but workaround #1 works as described. – user664303 Sep 27 '14 at 10:56

In dash type "gnome-keyboard-properties" this should open the keyboard preferences

or gksudo gedit /etc/default/keyboard

share|improve this answer
Thanks for the reply. The dashboard failed to open anything, but I'm now using Ubuntu 12.04 TLS and don't have this problem now. The command gksudo gedit /etc/default/keyboard did open a file from the command line. It contained the line XKBLAYOUT="gb". – Danny Crossley Aug 26 '12 at 10:28
  1. System Settings > Keyboard Layout > Language > Select + and select your language
  2. System Settings > Keyboard Layout > Format > Select your region
  3. System Settings > Keyboard Layout > Layouts > Select + and select your language


share|improve this answer

Is gnome-keyboard-properties part of Precise? Running that in dash or term doesn't do a thing. I guess that would explain some one my keyboard problems.

$ gnome-keyboard-properties gnome-keyboard-properties: command not found


$ wajig search gnome-keyboard-properties

doesn't bring anything up.

What does it install with?

share|improve this answer

I am using ubuntu 13.1 and had same problem.

In System Settings > Keyboard Layout > Language

there were 2 languages listed english (uk) english (us)

I deleted the english (us) option by selecting it then using the - key to delete it, so that only the english(uk) choice was listed in the box.

This seems to have worked and keyboard is correctly mapped


share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.