Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have Ubuntu 11.10. I have an English keyboard and have set the keyboard layout to English (UK) in the System settings -> Keyboard Layout. It is the only layout listed.

Recently my keyboard has gone to US layout. I don't know why and I cannot change it back.
The " and @ are in the wrong place.

I've typed man loadkeys and the documentation tells me that the default keymap is probably in a file called defkeymap.map either in /usr/share/keymaps or in /usr/src/linux/drivers/char. I can find neither of these directories. Can anybody tell me where the defkeymap.map file is in my distribution, or if it is there at all?

share|improve this question
add comment

5 Answers 5

I had the same issue. Even though English (UK) was selected for everything it was still using a US layout.

For some reason adding English (US) keyboard layout below the English (UK) entry in System Settings -> Region & Language -> Layouts made everything work.

share|improve this answer
1  
This solved it for me too on Ubuntu 13! I just had English (UK) selected and the character mapping of my british keyboard was totally screwed, even if when I clicked on the Keyboard Layout it showed the right one. I added the English (US) layout, which I don't need, but kept English (UK) layout selected and it immediately solved the issue! –  jbx Dec 13 '13 at 10:28
    
Similar problem in 14.04 after a fresh upgrade, and this fixed it. –  Emilio Pisanty Jun 25 at 10:39
add comment

In dash type "gnome-keyboard-properties" this should open the keyboard preferences

or gksudo gedit /etc/default/keyboard

share|improve this answer
    
Thanks for the reply. The dashboard failed to open anything, but I'm now using Ubuntu 12.04 TLS and don't have this problem now. The command gksudo gedit /etc/default/keyboard did open a file from the command line. It contained the line XKBLAYOUT="gb". –  Danny Crossley Aug 26 '12 at 10:28
add comment
  1. System Settings > Keyboard Layout > Language > Select + and select your language
  2. System Settings > Keyboard Layout > Format > Select your region
  3. System Settings > Keyboard Layout > Layouts > Select + and select your language

Done!

share|improve this answer
add comment

I have this problem in 14.04 According to everything that I look at I'm using En1 (UK) but it is actually En2 (US). eg

/etc/default/keyboard says "gb"

It switches back regularly. It says UK but it isn't. The keyboard layout chart shows things as they should be, but they aren't.

Workaround #1: If I switch from En1 to En2 & back it corrects itself until the next time I reboot.

It looks like we're dealing with this bug:

https://bugs.launchpad.net/ubuntu/+source/ibus/+bug/1284635

A workaround involving customising ibus-setup from this page did not work for me.

Removing Ibus seems to work. Hooray! Well it takes most of the Unity System Settings with it. Not good :(

Workaround #2: Look in your home directory & press control h to see hidden files. Open ~/.config/ibus/bus & delete the file therein. Then reboot.

This works until the next time that you do an upgrade, then you need to do it again, unless, after that first reboot, you change the permissions to make the file read-only.

share|improve this answer
    
add comment

Is gnome-keyboard-properties part of Precise? Running that in dash or term doesn't do a thing. I guess that would explain some one my keyboard problems.

$ gnome-keyboard-properties gnome-keyboard-properties: command not found

And

$ wajig search gnome-keyboard-properties

doesn't bring anything up.

What does it install with?

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.