Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm trying to configure quota for my / mount on Ubuntu 11.10. I have added ,usrjquota=quota.user,grpjquota=quota.group,jqfmt=vfsv0 to it in fstab. Made mount -o remount / and quotacheck -avugm. But when I try to turn quota on quotaon -avug i get this messages:
quotaon: using //quota.group on /dev/xvda1 [/]: No such process
quotaon: Quota format not supported in kernel.
quotaon: using //quota.user on /dev/xvda1 [/]: No such process
quotaon: Quota format not supported in kernel.

As I understood googling, that Ubuntu kernel could be compiled without quota support.

Any ideas?

Thanks!

share|improve this question
    
Did you build the quota files with quotacheck? –  psusi Mar 3 '12 at 4:29
    
If you mean this quotacheck -avugm, then yes, I did. –  Chuguniy Mar 3 '12 at 5:43
    
The default format may be vfsv1. Try either omitting the jqfmt option or specifying the format to quotacheck. –  psusi Mar 3 '12 at 7:32
    
How do I do that? I'm a beginner to whole UNIX/Linux thing, could you please explain or give some link on how to do it? Thanks! P.S. I have also tried to delete the defaults parameter from the / mount, no luck. –  Chuguniy Mar 3 '12 at 16:58
    
How to do what? NOT use the jgfmt option in fstab? –  psusi Mar 3 '12 at 18:24

1 Answer 1

There's a bug filled into launchpad which describes and solves this problem.

In summary, the quota module (and others) was removed from the virtual kernel. If you are in a Virtual Machine or aws-EC2 this should be your problem.

The solution

On Oneiric and Precise install linux-image-extra-virtual package. On old versions the modules should be already patched into kernel (just update your system).

After that run modprobe quota_v2 and modprobe quota_v1 in order to get ready to run quotas. Also remember to put the modules on /etc/modules.

Run your quotaon command as usual.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.