Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm running Ubuntu 11.10 64bit as a guest OS inside VMware Player 4.0.2 on a Windows 7 64 bit host OS. I have the latest VMware Tools installed (reinstalled it just in case). I'm using Gnome Classic, not Unity.

I'm finding that I run into screen redraw issues. If I move a window around, parts of the UI disappear. If menu pops up, pieces of it are left behind. This disappears after resizing the window (forcing a redraw), but that's very annoying.

I have another Ubuntu 11.04 VM that does not run into this issue. An example of the redraw issue can be found below.

Any help would be appreciated. Thank you.

Example image

share|improve this question
    
I've tried running in Unity and I don't get this. Must be an issue with Gnome Classic? –  Arthur Maltson Mar 6 '12 at 14:38
    
This probably won't fix your problem, but: I assume you have installed the Guest Additions in your vm, but it's worth mentioning. And,it's always a good idea to check if they have been updated and need to be reinstalled. –  Joe Mar 13 '12 at 21:50
    
Thanks Joe, I did try reinstalling VMware Tools. It really seems to be an issue with Gnome Classic + 64 bit Ubuntu + VMware Tools drivers for 64 bit. Oh well, I'm getting used to Unity, might give XFCE a try. –  Arthur Maltson Mar 15 '12 at 0:40
    
This question appears to be abandoned and unanswered, are you still looking for an answer? If this question no longer applies then you can either delete it or answer it yourself if you've solved the problem. Thanks! –  Eric Carvalho Apr 3 '13 at 1:21

1 Answer 1

The only solution I've found is to use 32 bit Ubuntu when in a VM and using Unity or Gnome. There seems to be an issue with the 64 bit version and the virtualized hardware. 64 bit Xubuntu seems to work well.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.