Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am running Ubuntu 11.10 and I own a Netgear N600 Wireless Dual Band Router with a USB port built into it. Naturally, the router came with instructions on how to mount and view this drive with both Windows and Mac, but nothing about Linux. I have an WD Elements 1 TB external HDD that I would like to plug into the router and share across my home network. However, when I plug it in, absolutely nothing happens on my desktop.

I checked on two different machines and nothing seems to indicate that the drive has been mounted (or is even seen at all) on either machine. I am fully aware that it may not be possible to do this with a Linux system, but I was hoping someone might have a suggestion.

share|improve this question
    
Can you add some commands to your question describing the instructions give to mount the drive under Windows? –  Bruno Pereira Mar 2 '12 at 21:19

6 Answers 6

up vote 2 down vote accepted

I have this same router and just figured out how to access an external drive via Ubuntu. I wrote a blog post with the details but here's the short version:

  1. Install the smbfs package (sudo aptitude install smbfs).
  2. Create a directory in which to mount your external hard drive (e.g., sudo mkdir /media/public).
  3. Add a line to the file /etc/fstab (gksudo gedit /etc/fstab) - at the end of the file add this line: //192.168.1.1/USB_Storage /media/public smbfs guest 0 0
  4. Save your newly updated fstab file then remount your drives (sudo mount -a); you should now be able to see your new external drive at /media/public.
share|improve this answer
1  
I do exactly what you said and I get this error "mount: unknown filesystem type 'smbfs'", to fix it I had to use cifs instead of smbfs –  Medya Mar 28 '13 at 13:30

Do you know your router's IP address? (usually 192.168.1.1, but it may vary).

Open a File Browser (Nautilus) window, then press Ctrl+L and in the location bar that appears type

smb://192.168.1.1

that may give you access to the disk, which is usually published to the network via the SMB protocol.

share|improve this answer

I have had similar issues with router a year ago. "roadmr" has a great potential solution, but there is a slight chance you might be on 192.168.0.1

in which case you would enter smb://192.168.0.1 (or other depending on your ip)

...although the most common would be 192.168.1.1 as "roadmr" suggested.

Apologies if you have already tried this, but... enter the terminal and type ifconfig.


This will display your IP information

I'm fairly new to Linux, but have worked with networks for a bit, so I just wanted to throw it out there to you that 192.168.1.1 might not be your IP, as I set my router to a more ambiguous IP, or I hide the network altogether.

share|improve this answer

As of 10/23/2012
You need CIFS not SAMBA :

  1. sudo apt-get install cifs-utils
  2. Add //192.168.1.1/USB_Storage /media/public cifs guest 0 0 to your /etc/fstab

I would not have gotten this far without the original answer so thank you.

share|improve this answer
    
Thank you this is the correct answer to this question, since cifs replaced smaba ! –  Medya Mar 28 '13 at 13:33

I used smbfs and after compiled it , you will find mount.smbfs under example script mount. I am sure you can get that from tar file after you installed binary? I used that command to mount. N600 does not seems to understand cifs.

share|improve this answer

Good instructions above to make the disk visible, but however, if you want to make it writable for the user, you have to define it with the uid & gid options in your mount command. To find out the uid (numerical User ID) & gid (numerical group ID) of your user, you can use the command:

id <user>

Then note the values in uid= and gid= -fields. Once done, you can test it by giving the following command:

sudo mount -o nosuid,uid=<insert uid here>,gid=<insert gid here> //192.168.1.1/USB_Storage/ /media/public/

If your disk is now writeable, then you can add the same permissions in the fstab entry:

//192.168.1.1/USB_Storage/ /media/public/ cifs guest,uid=<insert uid here>,gid=<insert gid here> 0 0
share|improve this answer

protected by Community Jul 27 '13 at 3:58

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.