Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Ok, So i've always had trouble with enabling 5.1 in ubuntu. Running 'alsamixer':

I have: Master, Heaphones, PCM, Front, Front Mi, Front Mi, Surround, Center All are at 100%

Card:HDA Intel

Chip:Realtek ALC888 (This is my onboard sound, Its a dell studio, with 7.1 integrated sound)

Running "speaker-test -c6 -twav" I only get the front 2 speakers (Right/Left) making any noise. The others make no noise at all.

I have no other sound card to use as all my PCI slots are used up.

Daemon.conf:

; daemonize = no ; fail = yes ; allow-module-loading = yes ; allow-exit = yes ; use-pid-file = yes ; system-instance = no ; enable-shm = yes ; shm-size-bytes = 0 # setting this 0 will use the system-default, usually 64 MiB ; lock-memory = no ; cpu-limit = no

; high-priority = yes ; nice-level = -11

; realtime-scheduling = yes ; realtime-priority = 5

; exit-idle-time = 20 ; scache-idle-time = 20

; dl-search-path = (depends on architecture)

; load-default-script-file = yes ; default-script-file =

; log-target = auto ; log-level = notice ; log-meta = no ; log-time = no ; log-backtrace = 0

resample-method = speex-float-1 ; enable-remixing = yes ; enable-lfe-remixing = no

flat-volumes = no

; rlimit-fsize = -1 ; rlimit-data = -1 ; rlimit-stack = -1 ; rlimit-core = -1 ; rlimit-as = -1 ; rlimit-rss = -1 ; rlimit-nproc = -1 ; rlimit-nofile = 256 ; rlimit-memlock = -1 ; rlimit-locks = -1 ; rlimit-sigpending = -1 ; rlimit-msgqueue = -1 ; rlimit-nice = 31 ; rlimit-rtprio = 9 ; rlimit-rttime = 1000000

; default-sample-format = s16le ; default-sample-rate = 44100 ; default-sample-channels = 6 ; default-channel-map = front-left,front-right

default-fragments = 8 default-fragment-size-msec = 10

share|improve this question

closed as too localized by fossfreedom Feb 29 '12 at 20:35

This question is unlikely to help any future visitors; it is only relevant to a small geographic area, a specific moment in time, or an extraordinarily narrow situation that is not generally applicable to the worldwide audience of the internet. For help making this question more broadly applicable, visit the help center.If this question can be reworded to fit the rules in the help center, please edit the question.

    
Could help if you make your question a little more detailed than saying "OMFG this works better in windows!!". What does your setting looks like? Is your hardware shown correctly in the sound preferences menu? –  tutuca Aug 9 '10 at 1:38
    
Please see the comments on the answers and update the question with new information. –  Li Lo Aug 10 '10 at 0:35
    
@tutuca - Alright calm down. It was just meant as a joke. @Li Lo - Will do. –  Will Aug 10 '10 at 0:43
    
In the "Output" tab of Sound Preferences do you have a connector like in this image? imgur.com/CIdor.png –  Li Lo Aug 10 '10 at 1:09
    
No, It looks like this: yfrog.com/5nselection001p By The way, Does this look right: "default-channel-map = front-left,front-right" Surely there should be rear-right center etc? –  Will Aug 10 '10 at 10:08

2 Answers 2

Try this:

Select sound preferences from sound indicator menu, go to hardware tab and select the applicable surround option from the profile menu.

If all goes well, you should have a working 5.1 sound.

share|improve this answer
    
Yep, that doesn't work ;) –  Will Aug 5 '10 at 21:34
    
What, exactly, doesn't work. How does it behave? –  Li Lo Aug 7 '10 at 13:11
    
Also which application are you trying to use to access the 5.1 sound? –  Ressu Aug 9 '10 at 4:45

You could try this in terminal:

sudo alsamixer

You should see separate "volume" sections (eg, Front, Line-In, Center/LFE, etc) that you can mute and unmute (pressing the 'm' key) or change the volume with the arrow keys.

If that doesn't work, then would you gladly clarify if you have a sound card (other than your motherboards sound). :D

share|improve this answer
    
Doesn't work, Its set as 5.1 in the "Sound" menu and all the channels are turned up fully in alsamixer. Using "speaker-test -Dplug:surround51 -c6 -l1 -twav" I can only hear the front left and right and in daemon.conf the default-sample-channels=6. I do have an audigy SB but the pci slot is taken up by my 9800gt... Thanks –  Will Aug 7 '10 at 15:50
    
Try "speaker-test -c6 -twav" i.e. without selecting the device. –  Li Lo Aug 7 '10 at 22:33
    
ONly the front 2 work again. No sound in any of the others –  Will Aug 10 '10 at 15:14

Not the answer you're looking for? Browse other questions tagged or ask your own question.