Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I am trying to update to install PHP 5.5, 5.6 or 7.0 in Ubuntu 12.04/14.04/16.04 LTS, and I can only get PHP 5.3.10 for Ubuntu 12.04, PHP 5.5.9 for Ubuntu 14.04 or PHP 7.0.4 for Ubuntu 16.04 using official repositories (using apt-get).

I'm not really sure how to do a manual update – as I need:

  • to play around with the new(est) PHP features
  • to install older PHP version due support in the software
share|improve this question
if sudo apt-get upgrade Dont upgrade PHP then try sudo apt-get dist-upgrade. For distribution upgrade. – Moiz Kiyani Oct 12 '13 at 16:19
up vote 225 down vote accepted

You could use a PPA to stay up-to-date with PHP or install previous version of PHP (f.e. PHP 5.6 on Ubuntu 16.04 LTS).

The most widely used repositories come from Ondřej Surý, the Debian PHP maintainer:

The php5 compat packages:

Deprecated repositories (use the main PHP PPA instead):

(Click here for instructions on using PPAs.)

PHP PPAs previously contained Apache 2.4 update. This is no longer a case, you need to add separate Apache 2.4 repository:

If you want use these PPAs, do this:

ppa:ondrej/php Launchpad logo (for PHP 5.5/PHP 5.6/ PHP 7.0)

sudo add-apt-repository ppa:ondrej/php
sudo apt-get update
sudo apt-get upgrade
sudo apt-get install php7.0   # for PHP 7.0
sudo apt-get install php5.6   # for PHP 5.6
sudo apt-get install php5.5   # for PHP 5.5

ppa:ondrej/php5-compat Launchpad logo (for php5 compat)

sudo add-apt-repository ppa:ondrej/php
sudo add-apt-repository ppa:ondrej/php5-compat
sudo apt-get update
sudo apt-get upgrade
sudo apt-get install php5 # this will pull php5.6 package 

ppa:ondrej/php5-5.6 Launchpad logo (for PHP 5.6; DEPRECATED)

sudo add-apt-repository ppa:ondrej/php5-5.6
sudo apt-get update
sudo apt-get upgrade
sudo apt-get install php5

ppa:ondrej/php5 Launchpad logo (for PHP 5.5; DEPRECATED)

sudo add-apt-repository ppa:ondrej/php5
sudo apt-get update
sudo apt-get upgrade
sudo apt-get install php5

If you don't have add-apt-repository binary do the following:

sudo apt-get install python-software-properties


PHP 5.4

Prepackaged latest PHP 5.4 now resides in separate PPA: ppa:ondrej/php5-oldstable Launchpad logo

Please be aware that PHP 5.4 has reached its end of life on 3. September 2015 and it doesn't receive any security updates. It's recommended to migrate to at least PHP 5.6 that will receive security updated till 31. December 2018.

share|improve this answer
Turns out you gotta run sudo apt-get update first! – kavisiegel Mar 5 '12 at 21:40
there is the php5-cli package for that! – matteosister Mar 7 '12 at 21:17
After adding the ppa, you could do: sudo apt-get dist-upgrade – matteosister Sep 23 '12 at 8:03
After installing the ppa, upgrading php and running php -v, the version information starts with this error message: Failed loading /usr/lib/php5/20090626/ /usr/lib/php5/20090626/ cannot open shared object file: No such file or directory Annoying. – systemovich Oct 24 '12 at 11:55
that's normal. Php 5.4 uses a new version of the zend library. When you upgrade to 5.4 the xdebug extension gets recompiled. You need to check inside /usr/lib/php5 the name of the folder. Mine is 20100525, should be yours too, and check if there is a file. Now edit the xdebug.ini file in /etc/php5/mods-available/xdebug.ini (or the symlinked /etc/php5/conf.d/**-xdebug.ini) and set the correct path to the file – matteosister Oct 24 '12 at 15:14

It will take some time for PHP 5.4 packages to make their way into Ubuntu, as there are an awful lot of dependency checks to do. Ubuntu 12.04 is now in beta so I doubt they'll upgrade it to PHP 5.4 (although I have no official or inside knowledge of this) -- it probably won't appear until Ubuntu 12.10 in October this year. If you want it sooner than that, you'll either have to find a third-party package or learn to build it yourself from the source code.

share|improve this answer

protected by Community Jan 28 '14 at 17:41

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.