Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

i'm using lenovo b570,it has got bcm4313 wlan chip from broadcom corp... the problem is that i'm not able to "enable wireless" from gui. even if enable wlan0 manually from terminal "ip link set wlan0 up".. it still fails to show the access points and even couldn't connect to any access point even from terminal...

share|improve this question
    
Which driver are you using ? Have you tried any solutions here askubuntu.com/questions/94021/… –  sagarchalise Mar 2 '12 at 12:06
    
ya tried... i use sta driver from additional drivers –  LavaKiran Naidu Mar 2 '12 at 12:17
    
Why can't I delete a comment? Ignore this. –  waltinator Mar 2 '12 at 22:35
    
Try my answer [here][1]. I have the same chip on my system, and it works. [1]: askubuntu.com/questions/90217/… –  waltinator Mar 2 '12 at 22:36

2 Answers 2

I'm having the same issue. Just bought this laptop yesterday. Lenovo B570, bestbuy. However, I'm using (trying to use) Kubuntu, just to be difficult. After install issues (blank screens, having to do blind walk on keyboard through parts of install) , it works fine for wired interface at least.

Waltinator's idea doesn't help. b43 shows up with lsmod. The network-manager widget-tray "thing" doesn't keep the "Enable wireless" box checked. After about a 1/2 sec after clicking it, it "un-checks" itself.

I have not replaced the stock drivers from kubuntu 11.10, per sagarchalise's suggestion because I wasn't initially convinced that the stock drivers aren't working.

Let me explain; this is what I've tried, right or wrong. The method to my madness is to forget about the GUI stuff when something isn't working and do it from the command line. All this done as root.

stop network-manager //kill network-manger gui, so doesn't conflict with our cli

ifconfig  // doesn't show wlan0

ifconfig  wlan0 up // turn on wireless

ifconfig // wlan0 shows up now

iwlist scan // wlan0 interface sees my wireless AP, so it's mostly receiving

iwconfig wlan0 essid what_ever_your_network_name_is // note i'm working without
//encryption, which is a whole 'nother can of worms

dhclient wlan0 //get an ip address for wlan0

ifconfig wlan0 //shows our ip address

ping 192.168.1.1 //ping to router works, right??

... no, not really... extremely slow if at all. Re-boots of machine have this very inconsistent. Sometimes hangs at dhclient. Did actually get a website to load 1/2 way before it died. Then DNS wasn't working to ping it, either. So I'm thinking sagarchalise may be right, but then it didn't help Naidu.

Naidu, does any of this command line testing work any different for you, with your different drivers??

The ping left running is extremely flakely... dropping pings for 10's of secs, then starts to work for a while..

Thanks, Steve

New status:

OK, I'm editing this now from the Lenovo B570 over the wireless link: it's working.

I let the ping to my local router run for like 5 minutes, and now it's solid. There is plenty of info in dmesg, but I hesitate to just cut & paste that large dmesg into the window here. In short, it does say "ADDRCONF(NETDEV_UP): wlan0: link is not ready" So it's a complete hack, who knows if I can repeat it after a power cycle.

Thanks, Steve

share|improve this answer

I switched to wicd & python GUI for network management. python networking tools to the rescue again.

Using a wired connection,

apt-get install wicd

apt-get purge network-manager

Power cycle.

It's working fine. Stock Ubuntu broadcom drivers. Using it now, on my encrypted WPA2 wireless AP. Don't know if it's going to hang or disconnect. Ping in a window is checking for long term test. So far all of about 45 minutes.

Sorry for my long, twisted, post above. Once I had some confidence in the drivers working on the cli, and determining that the stock GUI wrappers are likely broken, then looking for a new GUI was my conclusion. Maybe there's consequences to not using the stock network-manager. YMMV. Good Luck.

Thanks, Steve

One more addition: I have another Lenovo Z61t, running Kubuntu 10.04 LTS which uses the ath5k wireless driver. This wicd fix works fine on that, too. I'd given up using the stock network-manager widget for connecting to secure wireless connections. Flaw-less. Just works. I'm a happy camper.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.