Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am looking to install brother MFC 7360.I have installed printer but as scanner concerned it is not working everytime when I try to run xsane it says device not connected, When I try to add brscan-skey to startup program it asks for command line. I am not sure what shall I write in command line. please help me thank and regards, Gourik Goswami

share|improve this question
    
"For Brother USB scanners" "look at lsusb for the id like 04f9 is and save the file Restart udev sudo /etc/init.d/udev restart or sudo service udev restart" could you explain how to save the file for the info I see when typing lsusb? –  user143142 Mar 24 '13 at 23:29
add comment

6 Answers

For USB you have to edit the /lib/udev/rules.d/40-libsane.rules with root-rights and insert

Brother scanners

ATTRS{idVendor}=="04f9", ENV{libsane_matched}="yes"

in top of

"# The following rule will disable ..."

look at lsusb for the id like 04f9 is and save the file Restart udev sudo /etc/init.d/udev restart or sudo service udev restart

good luck mick

share|improve this answer
add comment
  1. Download driver to this link.
  2. Open terminal.
  3. Go to folder with driver downloaded.
  4. sudo dpkg -i --force-all** (scanner-drivername)
  5. Now you can use your scanner.
share|improve this answer
add comment

Follow instructions given in Brother website

In the download page, you should check for matching version (MFC-7360n), I think brscan4 should work.

share|improve this answer
add comment

This worked for me:

wget http://download.brother.com/welcome/dlf006646/brscan4-0.4.1-5.i386.deb
wget http://download.brother.com/welcome/dlf006654/brother-udev-rule-type1-1.0.0-1.all.deb
dpkg -i brscan4*.deb
dpkg -i brother-udev-rule-type1*.deb
share|improve this answer
add comment

I just got this printer and had the same problem...

I enabled printing (mahalo brother for supporting linux), but scanning was not forthcoming.

I installed the drivers provided by Brother:

http://welcome.solutions.brother.com/bsc/public_s/id/linux/en/download_scn.html

And still nada...

After some work and research, I found that sane (Scanner Access Now Easy), the API that provides access to the scanner in GNU/Linux does not currently support scanner connectivity over the network.

So I hooked up my printer/scanner via USB and was able to connect, sort of... I also had to change the permissions of the device>

To find out where the printer was mounted:

lsusb

Output:

Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 006 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 002 Device 003: ID 04f2:b175 Chicony Electronics Co., Ltd 4-Port Hub
Bus 004 Device 002: ID 046d:c52e Logitech, Inc. 
Bus 002 Device 007: ID 04f9:0270 Brother Industries, Ltd 

then changed the device permissions (full access for everyone):

chmod 777 /dev/bus/usb/002/007

Now I'm able to use the Ubuntu simple scan utility to do scanning as long as I'm connected via usb.

I'd love to know if anyone has any solutions for Network scanning on this model!

share|improve this answer
    
Giving world access to your usb port is BAD. The correct way to fix the permissions issue is described Michael Lang's answer above. I highly recommend deleting this answer before someone more strict down votes it. –  virtualxtc Dec 17 '13 at 4:06
add comment

I got the scanner to work (internet connected) by entering the command from this site: http://www.maxsoftprojects.com/2012/05/how-to-installa-mfc-7360n-on-ubuntu.html

brsaneconfig4 -a name=SCANNER model=MFC7360N ip=192.168.1.53
share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.