Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'll try to make this scenario as clear as possible.

  • Laptop Specs HP dv6-2189la:
    • 500 HDD
    • 4GB Ram
    • Intel i7

Personal Specs - Linux newbie running for the first time. Quite confused :(

I had Windows 7 x64, decided to start fresh new so I planned on formatting. Since I use it for work and didn't require it for another week, I didn't rush into installing Win 7 immediately as I wanted to try Ubuntu for quite a while.

1) Downloaded Ubuntu 11.10
2) Burned ISO to CD
3) Installed Ubuntu using the full HDD of 500GB erasing Win7
4) Ubuntu ran awesome (especially for me being a Linux Newbie from scratch)

I used Ubuntu for a while, but now I need to get back to work with Win 7. Tried running the installation CD for Win 7 and it just skips to Ubuntu without loading. Checked BIOS, tried other discs, even tried the disc on another computer and it works.

Since that didn't work, I tried running Win XP. This CD does load, it starts loading files, drives, kernel, blah blah and before even getting to install it Blue screens with error 0x0000007b.

I already used Gparted and created up to 250 GB space for Windows. Formatted to NTFS.

I really don´t know what do now. I've tried almost everything I know within my knowledge. I could say I'm an advanced PC user, but I bumped into the Linux wall starting from scratch.

All suggestions will be appreciated.

Thanks!

share|improve this question
    
have you checked your drive? –  yinon Apr 10 '12 at 7:02

6 Answers 6

Well, the only thing you need to do is to make sure in your BIOS boot menu CD has priority over booting from the hard drive. After that you reboot, and provided that you inserted a proper bootable CD/DVD, the setup program should start.

Ubuntu (or any other OS installed on your hard disk) has absolutely no control or influence over this process.

So, if your Win7 setup disk brings you to Ubuntu it means it's not bootable, unreadable or has some other problem, so BIOS skips it and proceeds to the next boot option, which is the hard disk.

Similarly, WinXP setup failing has absolutely nothing to do with Ubuntu - most likely it just does not have required drivers to access some of your hardware.

(also, "I bumped into the Linux wall" is just plain unfair - Ubuntu installed and booted on your machine without problems, isn't it? Blue Screen of Death is not Linux fault, it's Windows problem)

share|improve this answer

I had the exact same issue with an Acer Aspire machine. Took me a while to figure this out. This is NOT a linux issue. What you should try is changing your hard disk mode from ATAPI to IDE.

Prior to booting from the Win XP installation CD, hit the F2 key to enter your BIOS settings. Find your way to the hard disk section and modify it's mode to IDE. Make sure you save your changes before you exit the BIOS menu. Then, continue with the Win XP installation. You should now be able to continue with the installation without the annoying BSOD.

Make sure you choose your pre-prepared NTFS partition to install XP to. The option to do this will be provided in the blue DOS screen before the GUI installer starts. Use the arrows to choose your partition and hit 'Enter' for choosing it.

I've heard of XP installations that would assign a letter different than 'C' to this partition. This is not good. It will require some changes after the windows installation - from the XP os, involving remapping of the drive letter. However, I did not encounter this problem.

After the Win XP installation, you'll need to restore the master boot record that windows overwrites. Due to this issue, you'll not be able to boot Ubuntu. The data and partitions are there - just the MBR is gone. This is a two line fix and there are plenty of links regarding how to do this. I'll provide the shortest way here (assuming you did not back up your MBR using the 'dd' command:

Shortest way is to boot from the Ubuntu live CD, then restore the MBR using the boot repair utility:

Open a terminal and type this:

sudo add-apt-repository ppa:yannubuntu/boot-repair && sudo apt-get update
sudo apt-get install -y boot-repair && boot-repair

From the Boot repair window that opens - click the 'recommended repair' button. This will restore the MBR and grub settings but will not add the windows boot option.

So, finally, exit the live CD and boot normally. Choose Ubuntu from the now existing grub menu. When your Ubuntu OS starts, open a terminal window and update your grub settings:

sudu update-grub

This will update your grub menu with the new windows XP option and you are now ready to go and can dual boot to either operating systems.

share|improve this answer
    
Don't be afraid if the wrong drive letter is given, Windows will adjust. Other apps will adjust. I've been running like this for ages and have seen no problems, except for occasionally typing the wrong drive letter in commands, and that's generally my own stupidity. –  hexafraction May 21 '12 at 20:42

It has been my experience to load Windows first and then load Linux. In the book Linux for Dummies this was one of the recommendations made...Windows first, Linux second.

share|improve this answer

I can suggest one thing, and will try remind you two things.

  • I remember that, some XP installation CDs are broken. Fails during install.
  • If BIOS decides what to load (CD / Hdd / USB), linux distro can not decide.
  • Check you Hard Disk partitioning method please.

Last thing; If you succeed installing Windows, you won't be able to see GNU/Linux partitions and OS. (Windows' choice again..)

Regards.

share|improve this answer

Your disc drive may not be able to read your disk properly. You can be sure by configuring the Bios to boot only from CD so he won't even look at the hard drive and even then you'll get the same situation.

You can try installing from dok, as i see it Seven is to heavy so you must have burned it into a DVD disc in contrast to XP which is much more lighter and is burned into a CD-ROM disc. The problem is in your disc drive, it support CD-ROM but not DVD, GET IT?

good like in seven, as this picture would say (too bad i can't put it here (: ): http://ftp.math.sk/ftp/images/microshit.jpg

share|improve this answer

I quite understand your situation because I experienced that in one of my Sony VIAO laptop. After installing Ubuntu and installed Windows 7 later only to find out that I couldn't boot to Windows 7 environment.The thing I did that worked freely for me was to install Windows first then install Ubuntu later whose grub override Windows allowing me to make a choice of which to choose from. This was how I did it:

Step I:

Install windows 7, during the process create at least three partitions(if you have enough hard disk space).

Step II:

After installing Windows 7, insert the Ubuntu DVD/CD and try to do the installation. The Ubuntu would ask you the location you are willing to install the OS. Here you have to look carefully. The different partitions usage and free spaces displayed would tell you the one containing your Windows 7(Please, don't select this one for Ubuntu installation).

Step III:

Make a choice between the remaining two free partitions. Click the one of your choice and the popup windows will ask for what type of partitioning you want. Select the backward slash( \ ) and click Next or simply depress Enter key to continue.

Step IV:

The installation starts immediately and you would have to follow instruction along till you finish the installation.

When your system restart the GRUB would be displayed counting seconds to boot to Ubuntu.If you are interested in booting to Windows, simply use the downward/upper arrow keys to move there and press ENTER key.

I hope that helps.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.