Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Unable to select packages to be updated

Ubuntu 11.10 is installed, and I have updated my system via Ubuntu Software Centre, and after the update 3 updates remain in the list. But I am unable to select them, the tickboxes cannot be checked and Ubuntu Software Centre gives no error when I try to check.

Also, below it says "There is no update to be installed" and even though there seems to be updates Install Updates button is unclickable.

What should I do in order to install these updates?

share|improve this question
    
The bug from Radu Rădeanu is clearly related to askubuntu.com/questions/349555/…, the same packages are involved with a small difference: his bug includes translation updates. I tried sudo apt-get clean, sudo apt-get autoremove and sudo apt-get upgrade, but they didn't work, as in previous answer. "Be patient and wait" could be done only if its not a serious security matter. –  benditoelqueviene Oct 2 '13 at 14:46

2 Answers 2

up vote 3 down vote accepted

This happens when you have dependencies that are not met or are unsatisfied. As @BlueXrider suggested, you should first try installing updates from the terminal. If it doesn't work, then you should just be patient and wait. You should be able to install the updates as soon as the required/dependent packages are up to the required version.

share|improve this answer
    
There are also other people who are in the same situation with me with the same packages, so your answer is the solution: I need to wait till the dependencies are updated. –  Şâkir Aşçı Mar 2 '12 at 12:23
    
@ŞâkirAşçı Thank you. –  Swarnendu Biswas Mar 3 '12 at 1:26

Open dash/terminal

sudo apt-get update 

Then

sudo apt-get clean

Then

sudo apt-get autoremove

Then

sudo apt-get upgrade
share|improve this answer
    
I already tried these commands (except sudo apt-get clean & sudo apt-get autoremove). Now, I tried those two and no change. I guess the problem is related to packages as @Swarnendu Biswas suggests and I need to wait. Thank you for helping. –  Şâkir Aşçı Mar 2 '12 at 12:21

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.