Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm trying to upgrade from 11.04 to 11.10, but get this error:

An unresolvable problem occurred while calculating the upgrade: E:Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.

This can be caused by: * Upgrading to a pre-release version of Ubuntu * Running the current pre-release version of Ubuntu * Unofficial software packages not provided by Ubuntu

If none of this applies, then please report this bug using the command 'ubuntu-bug update-manager' in a terminal.

To attempt to fix this, I disabled all software sources not provided by Ubuntu, and I uninstalled all software not provided by Ubuntu in the Ubuntu Software Center. Synaptic tells me I still have natty/restricted nvidia-current, nvidia-glx-180, and nvidia-glx-185 installed. Could these last packages be what is holding back the upgrade? I hesitate to uninstall them because I'm worried that doing so may significantly reduce my screen resolution. What can I do to find out what packages are holding back the upgrade?

Update:

Running

sudo apt-get remove libglib2-ruby1.8

fixed the problem and allowed the upgrade to complete successfully.

share|improve this question

closed as off topic by Jorge Castro, Marco Ceppi Mar 8 '12 at 1:44

Questions on Ask Ubuntu are expected to relate to Ubuntu within the scope defined by the community. Consider editing the question or leaving comments for improvement if you believe the question can be reworded to fit within the scope. Read more about reopening questions here.If this question can be reworded to fit the rules in the help center, please edit the question.

    
restricted nvidia drivers do come from official repositories. you've got something else going on here. did you pin any packages? –  hbdgaf Mar 1 '12 at 21:54
    
@aking1012, no packages are pinned so far as I know, which I researched as follows: dpkg --get-selections | grep hold returns nothing, and I created a custom filter in Synaptic for pinned packages and that filter shows no results also. Is there another way I could find out if any packages are pinned? Would a log from my /var/log/dist-upgrade/ directory show what packages prevent the upgrade? I've tried interpreting those logs but haven't been able to figure out whether they answer my question. –  timblack1 Mar 2 '12 at 4:01
    
I'm not the one to ask about those particular logs. I almost never dist-upgrade. I leapfrog from LTS to LTS for boxes with complicated configs and re-install others. I just figured a pinned package would hold you up. It might be a quick hack-ish fix to stop problems like this: askubuntu.com/questions/41303/… ... Definitely turn off binary drivers during dist-upgrade and probably remove the packages. –  hbdgaf Mar 2 '12 at 4:45
    
Ok, I followed your recommendation to disable and remove the binary nvidia drivers, and still get the same error when I try to run the upgrade. So I submitted a bug report here bugs.launchpad.net/ubuntu/+source/update-manager/+bug/944962 and will pursue the issue there rather than here for now. –  timblack1 Mar 2 '12 at 17:11

Browse other questions tagged or ask your own question.