Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Well, I did a partial upgrade and it included removing gimp. I said myselfs:"ah, I'll reinstall it later". But I can't!!!! When I try to install it, thats wot I got:

The following packages have unmet dependencies:
gimp : Depends: libgimp2.0 (>= 2.7.5) but it is not going to be installed
Depends: libgimp2.0 (<= 2.7.5-z) but it is not going to be installed
Depends: libglib2.0-0 (>= 2.31.2) but 2.30.0-0ubuntu4 is to be installed
E: Unable to correct problems, you have held broken packages.

I want my gimp back! help pls!

share|improve this question

4 Answers 4

Unless I'm reading that wrong, those versions aren't the default Ubuntu versions. From what I can see, the latest version of Gimp and libgimp in Ubuntu 11.10 is 2.6.11-2. This hints that you have some sort of external repository installed.

Remove that source (The Software Sources program can help out there) and you should be able to install the proper current Ubuntu version.

Edit: your comment shows that there's even more that's been upgraded and now can't be downgraded. To remove a PPA cleanly (and get back to normality) follow this sequence:

  • Install ppa-purge
  • Make sure the PPA/source you were using is active in your sources. If you've already removed it, add it again.
  • Use ppa-purge to nuke the source:

    sudo ppa-purge ppa:repository-name/subdirectory
    

    (replacing repository-name/subdirectory with the details of the PPA you were using)

More information:

share|improve this answer
    
I removed the sources, updated, and when I tried to reinstall, I got pastebin.com/Q53yzGj7 –  Maor Mar 1 '12 at 13:50
    
@Maor Edited for removing PPAs better. –  Oli Mar 1 '12 at 15:07

Maybe it's a obvious suggestion, but have you tried to fix dependencies with

sudo apt-get install -f 

? When happened to me, I had sometime to remove all the packages involved one by one, until the dependency error got away. It happened for me on gimp too, the problem was an old libtiff hanging around.

share|improve this answer

You could try to install each dependency or as a "cheat" for me for cases like this I use synaptic. Have a app that gave the same problem, don't remember which. Install synaptic package and from there I install gimp. It solved the dependencies.

You could also try to reinstall it: sudo apt-get install --reinstall gimp. Just in case something was left without uninstalling, the reinstall will pick it up and notice.

share|improve this answer
    
after I removed the sources and updated, when I tried to reinstall I got that: pastebin.com/Q53yzGj7 –  Maor Mar 1 '12 at 13:52
    
In that case I would suggest what Oli said but additionally verify that those dependencies do not already exist with a wron version. If they do then purge them. For example the first one would be sudo apt-get purge python-gtk2. But note that if some of this involves removing other packages then do that one. Do this for all dependencies that show there and afterwards do a sudo apt-get update. Then try to install gimp again. –  Luis Mar 1 '12 at 15:45

The issue with the ppa's current 2.7.5 build is that when it was built it had a mistake in the /debian/control file concerning libgimp2.0, as in

Depends: ${shlibs:Depends}, ${misc:Depends}, libglib2.0 (>= 2.30.2)

That should have been libglib2.0-0

The end result is the libgimp2.0 has a dual dependency on libglib2.0-0 which is correct & libglib2.0 which is incorrect & cannot be satisfied

This can clearly be seen in the package's control file

Depends: libc6 (>= 2.11), libcairo2 (>= 1.2.4), libgdk-pixbuf2.0-0 (>= 2.22.0),   
libglib2.0-0 (>= 2.30.2), libgtk2.0-0 (>= 2.24.0), libpango1.0-0 (>= 1.22.0),    
libglib2.0 (>= 2.30.2)

The author has been notified, hopefully he will correct this, you can do yourself but that's beyond the bounds of this question I suspect

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.