Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Note: For some more details, some of which may not be true given what I've figured out, see this post.

When I first boot my computer, video performance (both native H.264 HTML5 in YouTube and Vimeo, and in Flash) in Chrome is perfectly reasonable. CPU usage stays slow, everything works correctly, and the video is silky-smooth.

But for whatever reason, if I suspend my computer then wake it up, video performance plummets. Full screen HTML5 video is choppy at best, and full-screen Flash video basically brings my computer to its knees (I'm talking less than a frame a second, and a 5 second lead time to leave full-screen after hitting Esc). Restarting Chrome doesn't fix this — I need to completely restart my machine before performance goes back to normal. Video performance in other applications, such as Movie Player, doesn't seem to be affected at all by the suspend cycle — it's only Chrome.

I'm using a Lenovo X201, with an Intel GMA HD graphics chipset, and Intel compnents all around (I don't need any proprietary drivers). This didn't happen in 10.04, and I haven't anything that I think would have caused this to happen. It's possible that a Chrome release could have caused this, but it seems less likely than a regression between 10.04 and 10.10.

Any ideas?

EDIT: In response Georg's comment, logging in and out doesn't fix it. Restarting Compiz or switching to Metacity (at least by using "compiz/metacity --replace & disown" — am I doing it right?) doesn't help (actually, it seemed to help somewhat with Flash once, but I haven't been able to reproduce this). I'm not sure about GDM — when I use "sudo restart gdm" I get kicked back to the Linux shell (?), which I have no idea how to get out of.

Also, I want to make very clear that this isn't just a case of Flash sucking (it does,but that's beside the point). I"m seeing the same general problem with HTML5 videos, and Flash is performing better on my Nexus One than it does on my Core i5 laptop. There's something screwy going on with Chrome and/or 10.10.

share|improve this question
    
To narrow the problem down: Does loggin out and in again fix it? Does restarting your window manager (GDM probably) fix it? Does restarting X fix it? –  Georg Schölly Nov 2 '10 at 15:59
    
@Georg: See the end of the main question for more details. –  unused Nov 5 '10 at 3:42
    
Try total X kill, like Alt-PrtScr-K. And what about Firefox? –  Extender Nov 5 '10 at 5:46
    
Heaslip: you can switch between the text consoles and GDM usign ctrl+alt+F1-F7 (7 or 8 is usually the graphic environment). Did you try killing X? (sudo kill Xorg) –  Georg Schölly Nov 5 '10 at 12:21
add comment

1 Answer 1

Upgrading to the new Chrome 8 beta fixed my problem with HTML5 video completely, since it added GPU acceleration. Flash is still as slugish as ever, but it runs well enough in Firefox, which isn't a problem for me since I've been using Firefox as my "crap, I need Flash for this" browser for a while anyway (I've had Flash disabled in Chrome 99% of the time for a while).

This isn't really an answer so much as an admission of defeat, but pending an actual solution, I think it's probably the most sensible advice for most people.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.