Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I did set up VSFTPD on my server and can successfully login using a user that has root permission on the server. However, I cannot create any directories outside of the user's home directory. Any idea why that is?

I have the option

write_enable=YES

enabled.

Thanks for any help!

share|improve this question

2 Answers 2

chroot_local_user=YES

chroot_local_user If set to YES, local users will be (by default) placed in a chroot() jail in their home directory after login. Warning: This option has security implications, especially if the users have upload permission, or shell access. Only enable if you know what you are doing. Note that these security implications are not vsftpd specific. They apply to all FTP daemons which offer to put local users in chroot() jails.

Source

share|improve this answer

It is not wise to do this.

That being said, i think you can just specify:

nopriv_user=root # or maybe toor

Try that?

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.