Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am getting following image everytime I try playing videos on Youtube or FB. I have already tried uninstalling flashlugin and then installing again. But, it didnt help. I also tried installing it via Synaptics, but even that didnt help.

enter image description here

share|improve this question
    
looks to me like you have some other plugin that is overriding the flash plugin –  hbdgaf Mar 1 '12 at 2:55
    
Go to here in the address bar: about:plugins Do you see "Shockwave Flash" in there? Also, what is the output of update-alternatives --list mozilla-flashplugin? –  Githlar Mar 1 '12 at 2:56
    
Yes, I see 2 entries for Shockwave Flash. pkansal@ubuntu:~/$ update-alternatives --list mozilla-flashplugin /usr/lib/adobe-flashplugin/libflashplayer.so –  Piyush Kansal Mar 1 '12 at 3:54
2  
Have you tried this add-on? –  user25656 Mar 1 '12 at 7:03
1  
Thanks. It worked after removing entry for Shockwave Flash. –  Piyush Kansal Mar 2 '12 at 22:43

4 Answers 4

up vote -1 down vote accepted

Just install the Flash-Aid plugin. It will choose the flash version for your browser version. It worked for me even when adobe said that they will not support flash for FireFox anymore. https://addons.mozilla.org/en-US/firefox/addon/flash-aid/

share|improve this answer
    
@jaorizabal: haha, anymore, really? So maybe you can say me, why Adobe add sandboxing to Flash for Firefox? :DD to Piyush Kansal: this solution was given by user vasa1 at comments to your question. –  swift Mar 18 '12 at 1:52
    
Where you read about stopping support? Give link please. No one ask here will Adobe Flash support Firefox. But all what is needed to know it is "Will Firefox support Adobe Flash?". Just it inadequate intention, dear friend. So, please edit your answer. And do not forget link tag @vasa1 please. Because it's his answer. Even without hope for point. Look question comments: "Have you tried this add-on? – vasa1 Mar 1 at 7:03". Thank you in advance. –  swift Mar 18 '12 at 2:53

"Terminal Way" for people who's avoid plugins:

Remove gnash and lightspark packages:

sudo apt-get --yes purge browser-plugin-lightspark
sudo apt-get --yes purge lightspark-common
sudo apt-get --yes purge browser-plugin-gnash
sudo apt-get --yes purge gnash-common

Then download file flashplayer*_XX_YYYYYY.tar.gz from http://get.adobe.com/flashplayer to some tmp directory.

cd /home/USERNAME/tmp

Unpack libflashplayer.so from archive, setting chmod, installing, hardlinking:

tar xvf *flash* libflashplayer.so
sudo chown root:root libflashplayer.so
sudo chmod 0644 libflashplayer.so
sudo mv libflashplayer.so /usr/lib/mozilla/plugins/
sudo ln -s /usr/lib/mozilla/plugins/libflashplayer.so /usr/lib/firefox-addons/plugins/libflashplayer.so

Remove unneeded archive

rm -f *flash*

Although it is only one method to tune your flash.
Fine tuning of lightspark or gnash also can be good choice.

share|improve this answer
1  
For anyone who's interested this apparently also works for Chromium –  Explosion Pills May 6 '12 at 17:32

There is another nice alternative, based on the solution of installing the package flashplugin-installer.

Open a command line and type

sudo apt-get install flashplugin-installer

This will install the default flashplayer for firefox. But in my case I use Chromium because its faster and cooler than firefox, in my opinion. Now we have to tell chromium where to find the path of this installation, since it isn't set by default. To do that, we execute the following command:

sudo update-alternatives --install /usr/bin/flashplayer flashplayer /usr/lib/flashplugin-installer/libflashplayer.so 1

wich basically tells ubuntu "hey, there is a plugin library called flashplayer inside /usr/lib/flashplugin-installer/libflashplayer.so". Now if you reopen Chromium, or any other browser I guess (and this is the pro of this solution), you should have a nice working flash plugin.

One point to note is libflashplayer.so may be located in another folder, so be sure to check first if you can find the file. If you cannot find the file by browsing into this folder, try finding it by typing

locate libflashplayer

If you still cannot find it, make sure you have a valid flash plugin installed.

share|improve this answer

I had this problem from a fresh install of Ubuntu 11.10 a few days ago. It's fixed easily by going to your "Ubuntu Software Center", search for flash, and install "Adobe Flash plugin". It will install the latest flash player. MAKE SURE you do not have "Gnash" it really interferes.

share|improve this answer
    
Gnash is not there. I will try for Software Center option –  Piyush Kansal Mar 2 '12 at 1:32
    
I tried that too but it is still not working. Help please !! –  Piyush Kansal Mar 2 '12 at 4:05

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.