Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

When I'm connected to my school's wifi network, which is an enterprise WPA2 network, using PEAP authentication and MSCHAPv2, I get disconnected every 30 minutes to an hour. It won't reconnect, and the only way I can get it to reconnect to the network is to flip my hardware wifi kill switch (on my laptop, which is an MSI x350

Here's what I assume is the relevant output of lspci: 03:00.0 Network controller: Intel Corporation WiFi Link 5100

And here's (probably too much, but I don't know what's relevant) stuff from my system log:

http://pastebin.com/ApuRdbrX

I'm using Kubuntu 11.10 with the KDE4.8 backports. But I've been having this problem with this machine since I bought it and was using Ubuntu (unity) 11.04. The problem persists no matter whether I use the gnome network manager or KDE's.

Edit: I'm now using GNOME again, but having the same problems.

share|improve this question
    
MTU issue as per this one? askubuntu.com/questions/59335/… –  fossfreedom Jun 13 '12 at 14:03
    
Network Manager fixed several issues with their WPA Enterprise management. Nobody should experience this issue anymore. –  Braiam Jan 2 at 3:39
    
Close Voters: this question is from Feb 2012, hence not off topic because about an EOL version. –  guntbert Jan 2 at 16:22
    
@guntbert Is not being voted for EOL but for "bug". –  Braiam Jan 2 at 17:53
add comment

3 Answers 3

up vote 1 down vote accepted

It seems Network-Manager is too aggressive with changing access points and thus causing random dis/re-connections. Try with wicd

sudo apt-get install wicd
apt-get remove network-manager

Edit or create /etc/wicd/encryption/templates/peap-mschapv2 as follows:

name=PEAP with MSCHAPv2
author=Cereal
version = 1
require username *Username password *Password
-----
ctrl_interface=/var/run/wpa_supplicant
network={
        ssid="$_ESSID"
        scan_ssid=$_SCAN
        key_mgmt=WPA-EAP
        eap=PEAP
        phase2="auth=MSCHAPV2"
        identity="$_USERNAME"
        password="$_PASSWORD"
}

Now you need to enable this template for wicd (after which you need to close and re-open wicd or reboot):

echo "peap-mschapv2" >> /etc/wicd/encryption/templates/active
share|improve this answer
add comment

There have been past issues with the 5100 using 802.11n causing disconnecting as you describe.I a kernel update did not resolve your issues, another fix you could try is

sudo gedit /etc/modprobe.d/options.conf 

add this

options iwlagn 11n_disable=1 11n_disable50=1

reboot.

share|improve this answer
add comment

From the log it appears that you are roaming from one access point to another and that the driver is getting confused when this happens and needs to be reset with a new firmware load. I assume using the kill switch prompts the kernel driver to do that.

You may want to check with Intel to see if there is updated firmware available for download.

Failing that, it may make sense to avoid the roaming altogether. Some suggest substituting wicd for network manager. This site gives more information, but it basically says that you install wicd and doing so will remove networkmanager. I assume you would then have to use wicd to set the SSID to which connect. "Your mileage may vary."

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.