Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Basically, I want my windows to go wherever on the screen. I don't want to panel to be a block. How can I disable not being able to drag windows on top of not under the panel? Oh, and, yes: gnome-panel.

share|improve this question
add comment

3 Answers

Have you considered autohiding the panel and the setting a show delay so that it doesn't pop up AS SOON as you touch the top?

For the autohide just right click and check autohide from the panel properties menu. For the show delay hit ALT+f2 and type gconf-editor. Click EDIT > FIND and check both boxes. Search for "show_delay" and select the first result. Change the value to anything higher than 100. (I use 700, personally)

share|improve this answer
add comment

You can install the compiz settings manager, go to "window rules"under "window management" and write gnome-panel on the field labeled "bellow" (Note: I'm writing this in a computer with Portuguese localization and trying to translate the terms to English so some names may be slightly different).

share|improve this answer
    
Did this work for you? When I type gnome-panel into that box, nothing changes, even after a 'killall gnome-panel'. Using (type=dock) doesn't work, either... –  clicker4721 Nov 4 '10 at 21:52
add comment

In compiz-config, go to window rules and add type=Gnome-panel (case is important!) in the "Below" field.

Please note that alt+f2 will now be below as well, so add (title=Run Application) & (type=Dialog) to above.

Please note this DOES NOT WORK in Metacity

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.