Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

According to a WEB UPD8 post from july 2011, it is possible to install Faenza-styled icons on LibreOffice toolbar.

I can't install Faenza the traditional way on LO 3.5 (i.e., changing the toolbar icons from Crystal or Tango from inside the application's "Options" menu) and now those icons are broken.

Faenza was already installed but the update removed everything.

share|improve this question
    
How did you install Faenza for older LibreOffice versions?? –  Jakob Feb 29 '12 at 20:18
add comment

3 Answers

up vote 10 down vote accepted

Update manager, today updated LO to 3.5 also here (Ubuntu 11.04). As I was using same icon theme I noticed same issue.

Just copying faenza archive over /usr/share/libreoffice/share/config/images_crystal.zip was not enough. Comparing icon theme archives from LO 3.5 with faenza set, revealed two possible misplacements:

res/commanimagelist -> cmd
vlc/source/src      -> vlc/res

I expect that first one was responsible for this issues, although I changed both: download link (3.6 MB)

So after downloading this archive place it as /usr/share/libreoffice/share/config/images_crystal.zip and then setting view to crystal should show faenza icons again :)

screenshot

share|improve this answer
    
Woow you are amazing thank you very much :D –  Manck Mar 11 '12 at 17:53
    
LibreOffice now looks great. Thank you very much! –  quangtruong1985 Jun 14 '12 at 5:06
    
do you know how to make this work on libreoffice and 12.04? –  ivotron Mar 27 '13 at 17:48
    
i meant libreoffice-4.0/ubuntu-12.04 –  ivotron Mar 27 '13 at 18:05
add comment

This doesn't bring back Faenza icons to LibreOffice (if they had been there), but this should fix its icons:

You could try to (re)install the usual icon theme libreoffice-style-humanInstall libreoffice-style-human (click this link to do so) and choose it in Settings as follows:

Start LibreOffice and open the appropriate settings Dialog:

start lo

open options

Choose the correct icon theme:

options

Does this help?

share|improve this answer
    
I have it this way but now I want to install faenza –  Manck Feb 29 '12 at 20:41
    
AFAIK there are no Faenza icons for LibreOffice - so I wonder how you installed them for LibreOffice 3.4 as you mentioned in your question? –  Jakob Feb 29 '12 at 20:46
    
Something like this webupd8.org/2011/07/faenza-icons-for-libreoffice-toolbar.html the floder was different but it worked. –  Manck Feb 29 '12 at 20:58
    
So you should find out where the icons are stored, i.e. locate images_human.zip if you installed libreoffice-style-human. Then you should install a second icon theme you don't want to use, i.e. libreoffice-style-crystal. You should go to the icon folder (start Nautilus as sudo: sudo nautilus), backup the crystal icon theme, i.e. rename it to images_crystal.orig.zip, move the zip-file downloaded here to this forlder and name it images_crystal.zip. Then choose Crystal in LibreOffice. Don't know if this works in 3.5, though. –  Jakob Feb 29 '12 at 21:14
1  
What's the problem? If you don't describe exactly what doesn't work it's relatively difficult to help you. What did you try? –  Jakob Feb 29 '12 at 23:12
show 3 more comments

thanks for Your advice - but I have to make "my own" package include small icons... I am using it on mac and for it I need a small icons. So if You want I send You may .zip file. Michal

share|improve this answer
add comment

protected by Community Apr 16 '12 at 8:33

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.