Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Possible Duplicate:
How do I fix the GPG error “NO_PUBKEY”?

(Translation)

Having problems when I update the system via the terminal:

sudo apt-get update

W: GPG error: http://ppa.launchpad.net natty Release: The following signatures could not be verified because the public key is not available: NO_PUBKEY 5A9A06AEF9CB8DB0
(/ var/lib/apt/lists/archive.canonical.com_ubuntu_dists_oneiric_partner_binary-amd64_Packages)
W: Duplicate sources.list entry http://archive.canonical.com/ubuntu/ natty / i386 partner Packages (/ var/lib/apt/lists/archive.canonical.com_ubuntu_dists_oneiric_partner_binary-i386_Packages)

I'm maybe too many repositories?

(Original post)

habe nen Problem beim update des systems via terminal: sudo apt-get update

Kommt leider folgende Fehlermeldung:

W: GPG-Fehler: http://ppa.launchpad.net oneiric Release: Die folgenden Signaturen konnten nicht überprüft werden, weil ihr öffentlicher Schlüssel nicht verfügbar ist: NO_PUBKEY 5A9A06AEF9CB8DB0
(/var/lib/apt/lists/archive.canonical.com_ubuntu_dists_oneiric_partner_binary-amd64_Packages)
W: Duplicate sources.list entry http://archive.canonical.com/ubuntu/ oneiric/partner i386 Packages (/var/lib/apt/lists/archive.canonical.com_ubuntu_dists_oneiric_partner_binary-i386_Packages)

habe ich evtl zu viele repositorys?

Kann mir jemand weiterhelfen?!

Beste Grüße

share|improve this question
add comment

marked as duplicate by Javier Rivera, htorque, jokerdino, jrg Mar 1 '12 at 16:29

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

1 Answer

The reason is that this public key has not been added.

Get the Public Key. Which in your case is 5A9A06AEF9CB8DB0

Now add it, by typing this command in terminal

sudo apt-key adv --recv-key --keyserver keyserver.ubuntu.com 5A9A06AEF9CB8DB0

Now update it:

sudo apt-get update

Source: http://maketecheasier.com/fix-ubuntu-update-errors/2011/12/16

share|improve this answer
    
that is only part of the answer, he has a confliction of repositories also natty/oneiric –  Ringtail Feb 29 '12 at 17:47
    
OP what are you currently using? natty or oneiric? –  Ringtail Feb 29 '12 at 17:48
add comment

Not the answer you're looking for? Browse other questions tagged or ask your own question.