Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm trying to make GROMACS the error I'm getting is :

fatal error: glib.h: No such file or directory

I've seen that there are already questions related to this, and I followed their advice and ran the following:

sudo apt-get install libglib2.0-dev

I got

Reading package lists... Done
Building dependency tree       
Reading state information... Done
libglib2.0-dev is already the newest version.
0 upgraded, 0 newly installed, 0 to remove and 270 not upgraded.

After this, when I re-run make,why do I it still get the same error?

share|improve this question
add comment

1 Answer

I had a similar problem. You could try running locate glib.h. On my system the locate returns:

/home/jere/src/last.fm-1.4.2.58240/src/transcode/mpgli/mpglib/mpglib.h
/usr/include/dbus-1.0/dbus/dbus-glib.h
/usr/include/glib-2.0/glib.h
/usr/include/libdbusmenu-glib-0.4/libdbusmenu-glib/dbusmenu-glib.h
/usr/src/linux-headers-3.2.0-29-generic/include/config/blk/dev/bsglib.h

and I ended up adding the -I/usr/include/glib-2.0 to the include path of the compiler (in the Makefile).

I guess this is because not all linux distributions install the glib development files to the same folder.

share|improve this answer
    
How to add /usr/include/glib-2.0 to the include path of MakeFile? –  RSK Jan 14 at 9:54
    
It depends on how the Makefile is written. Can you give me an example of your Makefile? –  jeremija Jan 14 at 13:40
    
I was trying to set up ios-webkit-debug-proxy. Here is the generated MakeFile –  RSK Jan 15 at 6:11
    
I have not tried this, but I can see there is a file github.com/google/ios-webkit-debug-proxy/blob/master/src/… You could try adding the -I/usr/include/glib-2.0 to the AM_CPPFLAGS variable so that it looks like this: AM_CPPFLAGS = -I$(top_srcdir)/include -I/usr/include/glib-2.0 and then reruning the autogen.sh script. –  jeremija Jan 16 at 9:37
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.