Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

How do I disable the Ctrl + Q shortcut in Firefox without using the keyconfig extension?

share|improve this question
up vote 16 down vote accepted

There is now an extension just for that:

https://addons.mozilla.org/en-us/firefox/addon/disable-ctrl-q-shortcut/

share|improve this answer
1  
For those who are interested in using this plugin, it is restartless. – Can't Tell Dec 14 '14 at 4:14

You can find instructions on how to modify key bindings without keyconfig at http://www-archive.mozilla.org/unix/customizing.html#keys

share|improve this answer
1  
I could not get it working. Could you please list the exact steps to be followed? – 3l4ng Jul 5 '15 at 18:02

Bear in mind that not all actions can be customized without an extension.

I use keyconfig to move into tabs prev/next by using ,/.

share|improve this answer

You should obtain a similar result, easier, enabling the hidden config option (about:config).

  1. In Firefox's address bar, type about:config and accept the warning that it will give. Now it appears in front of you a long list of config options. Filter it typing the keyword quit in the filter bar (up top). After that the filter acts you will have only few lines. Click on browser.showQuitWarning and set it true by clicking on it.

  2. You can use this filter again with the keyword warnon and see if the options "warn when close tabs" and similar are set to true.

  3. In the Firefox's Options/Preferences (or Edit/preferences it depends from system and version), go to the Tabs section and check the option "Warn me when closing multiple tabs". This will prevent you to close a window with multiple tab.

You will not completely disable CTRL-Q but at least you will make it harmless.

share|improve this answer
1  
Unfortunately, for me (on Ubuntu 14.10 with Firefox 33.0), setting the key "browser.showQuitWarning" to "true" does absolutely nothing. :-( So I had to install the above mentioned extension just to disable keyboard shortcut. What a world we live in. – okolnost Nov 22 '14 at 13:43
    
It just worked for me with 14.04. – arhuaco Jun 4 '15 at 16:22

protected by Community Dec 28 '15 at 8:19

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.