Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am getting the following errors when i am running aptana

A Java Runtime Environment (JRE) or Java Development Kit (JDK)
must be available in order to run AptanaStudio3. No Java virtual machine
was found after searching the following locations:
/opt/aptanastudio3/jre/bin/java
java in your current PATH

.

300E7Z:~$ java -version
java version "1.7.0_03"
Java(TM) SE Runtime Environment (build 1.7.0_03-b04)
Java HotSpot(TM) Server VM (build 22.1-b02, mixed mode)

My JDK path is /usr/local/jdk1.7.0_03

share|improve this question
    
Are you still experiencing this issue? The latest version of Aptana with JRE from repository works for me. –  hbdgaf Apr 7 '12 at 23:35

4 Answers 4

What works for me
Install Eclipse from repository
sudo apt-get install libjpeg62
Install the plug-in instead of the portable
It all just works.

share|improve this answer

I had OpenJDK when i installed aptana. So i installed SunJava and this helped but still not much . Doing aptana -vm /path/to/sunjdk helped. But i wanted something simpler. So this is what finally helped me.

Uninstalling Aptana and restart the sytem.

Now install aptana again

share|improve this answer

My Ubuntu 12.04 also displayed the same error. I followed the instructions from the Thumbring blog and I could start Eclipse after that.

Run the following command:

sudo update-alternatives --install /usr/bin/java java /usr/lib/jvm/java-7-sun/bin/java 300  
sudo update-alternatives --install /usr/bin/javac javac /usr/lib/jvm/java-7-sun/bin/javac 300  
sudo update-alternatives --install /usr/bin/jar jar /usr/lib/jvm/java-7-sun/bin/jar 300   
sudo update-alternatives --install /usr/bin/javah javah /usr/lib/jvm/java-7-sun/bin/javah 300   
sudo update-alternatives --install /usr/bin/javap javap /usr/lib/jvm/java-7-sun/bin/javap 300   

And then, run this command:

sudo update-alternatives --config java  
share|improve this answer

Aptana is attempting to locate a JRE at the location /opt/aptanastudio3/jre/bin/java. However, there is no JRE at that location.

Create a symlink that points Aptana to the actual location of your JRE:

ln -s /usr/local/jdk1.7.0_03 /opt/aptanastudio3/jre/bin

This should then mean that you can locate the java executable at the path: /opt/aptanastudio3/jre/bin/java. This assumes the directory /opt/aptanastudio3/jre/ and /opt/aptanastudio3/jre/bin exist. If they don't, you'll need to create them.

share|improve this answer
    
still giving the same error –  aWebDeveloper Feb 29 '12 at 9:58

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.