Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Possible Duplicate:
Software center not opening

I just upgraded to 11.10 but i can't get software center work. Every time I click the icon, there is no responding. If I run sudo software-center in terminal, i get the following error code:

2012-02-29 01:33:46,899 - softwarecenter.ui.gtk3.em - INFO - EM's: 17 15 21
2012-02-29 01:33:47,677 - softwarecenter.backend.reviews - WARNING - Could not get usefulness from server, no username in config file
2012-02-29 01:33:47,743 - softwarecenter.ui.gtk3.utils - INFO - Softwarecenter style provider for radiance Gtk theme: /usr/share/software-center/ui/gtk3/css/softwarecenter.css
*** buffer overflow detected ***: /usr/bin/python terminated
======= Backtrace: =========
/lib/x86_64-linux-gnu/libc.so.6(__fortify_fail+0x37)[0x7fd02938a7f7]
/lib/x86_64-linux-gnu/libc.so.6(+0xf7710)[0x7fd029389710]
/usr/local/lib/enchant/libenchant_myspell.so(_ZN7HashMgr8add_wordEPKciiPtiS1_b+0x7b)[0x7fd00852b3bb]
/usr/local/lib/enchant/libenchant_myspell.so(_ZN7HashMgr11load_tablesEPKcS1_+0x268)[0x7fd00852bbe8]
/usr/local/lib/enchant/libenchant_myspell.so(_ZN7HashMgrC1EPKcS1_S1_+0xb2)[0x7fd00852bd82]
/usr/local/lib/enchant/libenchant_myspell.so(_ZN8HunspellC2EPKcS1_S1_+0x8a)[0x7fd00852c0ba]
/usr/local/lib/enchant/libenchant_myspell.so(_ZN14MySpellChecker17requestDictionaryEPKc+0x39d)[0x7fd0085394ed]
/usr/local/lib/enchant/libenchant_myspell.so(+0x29656)[0x7fd008539656]
/usr/local/lib/libenchant.so.1(+0x41b8)[0x7fd01a9151b8]
/usr/local/lib/libenchant.so.1(enchant_broker_request_dict+0xc3)[0x7fd01a9165b3]
/usr/lib/libwebkitgtk-3.0.so.0(+0x48cf53)[0x7fd01afa9f53]
/usr/lib/libwebkitgtk-3.0.so.0(+0x4c4bbe)[0x7fd01afe1bbe]
/usr/lib/libwebkitgtk-3.0.so.0(+0x4c546d)[0x7fd01afe246d]
/usr/lib/x86_64-linux-gnu/libgobject-2.0.so.0(g_type_create_instance+0x513)[0x7fd027f06373]
/usr/lib/x86_64-linux-gnu/libgobject-2.0.so.0(+0x125ac)[0x7fd027ee65ac]
/usr/lib/x86_64-linux-gnu/libgobject-2.0.so.0(g_object_newv+0x294)[0x7fd027ee8e94]
/usr/lib/python2.7/dist-packages/gi/_gobject/_gobject.so(+0xbcea)[0x7fd02639ccea]
/usr/lib/python2.7/dist-packages/gi/_gobject/_gobject.so(+0x14371)[0x7fd0263a5371]
/usr/bin/python[0x47c1d1]
/usr/bin/python(PyObject_Call+0x3a)[0x41ad2a]
/usr/bin/python(PyEval_EvalFrameEx+0x92e)[0x4b6b9e]
/usr/bin/python(PyEval_EvalCodeEx+0x13d)[0x4bcd2d]
/usr/bin/python[0x448edf]
/usr/bin/python(PyObject_Call+0x3a)[0x41ad2a]
/usr/bin/python[0x43074e]
/usr/bin/python(PyObject_Call+0x3a)[0x41ad2a]
/usr/bin/python[0x480c73]
/usr/bin/python[0x47c1d1]
/usr/bin/python(PyObject_Call+0x3a)[0x41ad2a]
/usr/bin/python(PyEval_EvalFrameEx+0x92e)[0x4b6b9e]
/usr/bin/python(PyEval_EvalCodeEx+0x13d)[0x4bcd2d]
/usr/bin/python[0x448edf]
/usr/bin/python(PyObject_Call+0x3a)[0x41ad2a]
/usr/bin/python[0x43074e]
/usr/bin/python(PyObject_Call+0x3a)[0x41ad2a]
/usr/bin/python[0x480c73]
/usr/bin/python[0x47c1d1]
/usr/bin/python(PyObject_Call+0x3a)[0x41ad2a]
/usr/bin/python(PyEval_EvalFrameEx+0x92e)[0x4b6b9e]
/usr/bin/python(PyEval_EvalCodeEx+0x735)[0x4bd325]
/usr/bin/python(PyEval_EvalFrameEx+0x7eb)[0x4b6a5b]
/usr/bin/python(PyEval_EvalFrameEx+0xb07)[0x4b6d77]

followed by Memory map.

However, sudo apt-get update & upgrade work fine, so does Synaptic Package Manager.

How can i fix this problem?

Thanks

share|improve this question

marked as duplicate by jokerdino, Eliah Kagan, Jorge Castro, Mitch, Tom Brossman Sep 8 '12 at 10:55

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

add comment

1 Answer 1

remove the config file for software-center then log out and back in

sudo rm -rf ~/.config/software-center
share|improve this answer
    
Thanks but it didn't fix the problem. When i log back in, i still get the same error code. –  Kevin Mar 1 '12 at 14:19
add comment

Not the answer you're looking for? Browse other questions tagged or ask your own question.