Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

i have a 1080p monitor connected to my pc running ubuntu via a vga cable,however when i installed the amd drivers from the additional drivers programme,ubuntu seems to think that my monitors maximum resolution is 1600x1200. This results in the screen being widened substantially, and everything being slightly fuzzy.

Im not really sure what to do, as i havent really used ubuntu before.

share|improve this question
add comment

2 Answers

Try going to the "display" menu. (See image for more info)

enter image description here

From here you should be able to select your various connected monitors and change their resolutions. It should look like this:

enter image description here

If u like the terminal, then xrandr should do it. Look into various commands either in man pages or on the internet.

Cheers!

share|improve this answer
    
If you have two monitors showing in above, make sure 'Mirror displays' is not checked as the resolution will be limited to the least capable monitor. –  James Feb 28 '12 at 23:03
    
yeah, Ive found out what i think is causing my problem. Ubuntu isn't detecting my monitors EDID properly. This is an issue that seems to happen to my monitor, no matter what os or hardware it's plugged into. Anyways, on windows it was easy to fix, as i would just go into the catalyst control center and disable EDID, which then allowed me to select my monitors correct resolution of 1080p. The trouble is though, that on Ubuntu i cant seem to disable it or change it whatsoever, ive tried downloading the linux catalyst, but that doesnt work, and ive tried xrandr but that doesnt work! –  PixelTwister Feb 29 '12 at 18:46
add comment

This worked for me. I put it in my .bashrc file, so whenever I want 1080p, I type go1080p.

alias go1080p='xrandr --newmode 1080p2 148.5 1920 2008 2052 2200 1080 1084 1089 1125 +hsync +vsync +preferred ; xrandr --addmode DVI-0 1080p2 ; xrandr --output DVI-0 --mode 1080p2'

I’m using DVI-0, but you can type xrandr|grep connect and look at the names it uses.

share|improve this answer
    
See also Ubuntu Wiki – X/Config/Resolution – “Adding undetected resolutions”. Those steps explain how to construct most of the command you posted. Two other sections on that page are also relevant: “Dynamically testing different resolutions” tells you how to test and apply your changes, and “Setting xrandr changes persistently” explains alternatives to creating an alias in your .bashrc file. –  Rory O'Kane Jul 19 '12 at 18:49
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.