Sign up ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free.

I've recently had some problems when I tried to install the latest gnome-shell and then revert back to the stable version. After I purged all the PPAs that I was using and reinstalled gnome-shell and everything, I found that things still weren't working quite right.

I found somewhere online (obviously a reputable source) that deleting my dconf config files from ~/.config/dconf/ and ~/.cache/dconf/ and then rebooting would help. While that did reset all my gnome-shell settings back to initial (like I wanted), I discovered another problem in that I could not change any settings on my system, via gnome-tweak-tool, System Settings, or dconf-editor. I would receive an error message of :

WARNING **: GDBus.Error:org.freedesktop.DBus.Error.ServiceUnknown: The name ca.desrt.dconf was not provided by any .service files

After much googling and fiddling, I was able to figure out that I could change settings if I ran /usr/lib/d-conf/dconf-service & and then changed all my settings while it was running.

I have two questions:

Would anyone know why something like this would happen (and is there anything I can do to fix it?


Is it terrible to add /usr/lib/d-conf/dconf-service/ to my startup applications so I'm able to change settings while using my computer day-to-day? This is really just a workaround, but I want to know if it's safe.


share|improve this question

2 Answers 2

up vote 1 down vote accepted

It seems that ca.desrt.dconf.service is missing from /usr/share/dbus-1/services/ . Try reinstalling dconf-gsettings-backend. It worked for me.

share|improve this answer
Thanks so much! For some reason ca.desrt.dconf.service was missing. Any idea why? Reinstalling that package in Synaptic seemed to fix it though. Thanks again! – jat255 Mar 18 '12 at 23:16

Doing a ps:

ps -ef|grep dconf
tthtlc    2912  2893  0 Aug07 ?        00:00:00 /usr/lib/ibus/ibus-dconf
tthtlc    4386  2695  0 Aug07 ?        00:00:00 /usr/lib/dconf/dconf-service

and who is his parent:

root      2440     0:00 lightdm
root      2469    18:07  \_ /usr/bin/X -core :0 -seat seat0 -auth /var/run/lightdm/root/:0 -nolisten tcp vt7 -novtswitch
root      2686     0:00  \_ lightdm --session-child 12 15
tthtlc    2695     0:00      \_ init --user

and so it is "init" which is called from lightdm (owned by root).

so clearly dconf-server is not root-owned, and therefore should not be started at boot time, but instead should be started AFTER user has authenticated through login shell, which then started the "init" and there after other programs.

(Notice that mine is Ubuntu 14.04 64-bit LTS).

For starting up dconf-service, read this - so essentially you don't have to start it youtself:

Users or administrators should never need to start the service, as it will be automatically started by dbus-daemon(1) whenever an application tries to write settings. Reading values from the dconf database does not involve the service; it is only needed for writes.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.