Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

So I've just installed Ubuntu 11.10 on my old PC. It has an nVidia 8500GT, and the Desktop monitor is pretty old though; like 1998 old. I have installed the drivers using this guide: how-to-install-nvidia-2750907-driver at mygeekopinions.blogspot.com

It's a CRT monitor. Philips 201b4. I guess that's the problem.

Could you help me get 1280by1024 or something? Thanks

xorg.conf

Section "Device"
    Identifier  "Default Device"
    Option  "NoLogo"    "True"
EndSection

xrandr -q

xrandr: Failed to get size of gamma for output default
Screen 0: minimum 320 x 240, current 640 x 480, maximum 640 x 480
default connected 640x480+0+0 0mm x 0mm
   640x480        50.0* 
   320x240        51.0  
share|improve this question

1 Answer 1

You could try this. This is all from the top of my head. So please be patient.

XORG WAY

  1. When booting go to the GRUB Menu (Pressing ESC or leaving SHIFT pressed should do the trick).

  2. Select the "Recovery" version of the option you always load. For example if you always load Ubuntu 3.0.16 then there must be a Ubuntu (Recovery) 3.0.16 below it as an option. Select that one.

  3. You will get to a menu that asks what do you want to do next. Select root in terminal.

  4. Type X -configure. This will create a new xorg.conf file.

  5. Test this new xorg file by typing X -config xorg.conf.new this should open a window with a resolution. If you see the mouse it works. If it gives an error then stop there since this is not the way. To escape press CTRL+C.

  6. If it worked then copy the new xorg.conf.new file to where the old xorg.conf. For example cp xorg.conf.new /etc/X11/xorg.conf.

  7. Type startx to see your new resolutions before rebooting the PC.

  8. If all is as it should be, you can safely reboot the PC and enjoy the new view.

NVIDIA WAY

  1. Go to the terminal, does not matter where you are and type sudo nvidia-xconfig

  2. Reboot. The nvidia tool should have done several checks to see the monitor and resolutions supported.

NOTE - In your case try the NVIDIA Way first since you have an Nvidia card already. This was done with a Markvision 1994 14' monitor that supports 1024x768 but somehow in Linux supports 1280x1024@50. How in the world. Don't ask me.

share|improve this answer
    
Thanks for your answer. I've managed to get 1024. But I need more.Look at those pics, maybe something is wrong? phota.me/pu8U.png and phota.me/WZjc.png . The first command did not work. It couldn't lock a certain file. And the xorg.conf file: pastie.org/private/1crt5czjjhd6agqhlegag . Thanks –  marcel Feb 28 '12 at 16:57
    
For the 2nd and 3rd image everything is good. The first Nvidia settings image is wrong. What I would have suggested would have been to install the PPA of Nvidia but I see you have already done that. Can you provide the inches of that monitor. I looked in google and came with a 19', 21', 22'... –  Luis Alvarado Feb 28 '12 at 18:03

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.