Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have installed Ubuntu 11.10 on an Asus p8z68 v-pro motherboard which is a UEFI bios. The install seems to have worked fine except for one thing, when restarting or shutting down it gets stuck at the Asus bios boot screen when starting up again (or blank screen if turning off the bios flash screen). This means I have to hold down the power button to turn it off and then back on again which boots ubuntu fine.

I have read a lot of the other questions and answers here and dont seem to find a problem/solution that matches this exactly.

I have ubuntu installed on a SSD and then have 2x2TB sata disks in a raid 1 array through intel storage technology and using dmraid to show the raid in ubuntu. Looking at the details for the disks in gparted, all the disks have an msdos partition table, and from what I can see there is not a EFI partition created.

I really dont want to have to reinstall everything if possible as its working well except for the restart glitch.

What things can I try to fix this problem or at least debug it (as it doesnt seem to even reach grub)?

UPDATE: I was sure this was a problem with the drive being a msdos partition table assuming that the EFI had not installed at all (I had a win7 installation on it previously so I wiped that with gparted before installing and must have put on a msdos partition table then). So I reinstalled Ubuntu with a USB install after wiping the ssd drive and setting it to gpt partition table. This correctly installed a Fat16 EFI partition at the beginning and I though everything was going to be rosey. However, it still seems there is a problem with reboot and shutdown except now it doesnt even show the bios splash, just a black screen with no prompt or anything.

share|improve this question

I found the answer at ubuntu forums. Adding the following to my grub seems to do the trick but it takes a while to reboot. NOTE: Do not do as suggested on that thread but instead add this to your /etc/default/grub file and then do update-grub:

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash vt.handoff=7 rootdelay=90 reboot=a,w"
share|improve this answer

i had this problem too and found a solution here:

you have to change your appearance theme from "ambience" to "radiant". once i did, the gear button showed up in the upper right corner and ubuntu actually shutdown when i told it too.

share|improve this answer

After you change to radiance gear button on my computer doe's not show. I have to send cursor off screen (far right as possible) then i get pull down menu and switch off.

share|improve this answer

For my system the following command worked...
sudo apt-get install laptop-mode-tools
and restart your system it will work properly.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.