Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

How do you switch Ubuntu to another (human) language without reinstalling it?

share|improve this question
add comment

5 Answers

up vote 22 down vote accepted

There are two ways to do this,

  • Go to system>administration>Language Support in your menu, and choose your language settings.

looks like DoR got the same thing as me

  • Before you log in, you can change your language (bottom left, select your language).
share|improve this answer
2  
+1 for pointing to the login screen. This gives us a per user option - very convenient :-) –  Takkat Nov 1 '10 at 22:03
add comment

System->Administration->Language Support
From here can change your current language or install new ones.

alt text

share|improve this answer
add comment

You can use "Language Support" to change the system's current language(s).

"Language Support" is located in the system settings (which you can find in the power menu), and can also be found directly in the dash by typing "Language".

enter image description here

Use "Install / Remove Languages…" to download and install a language that is not currently on the list, and then drag/drop the listed entries according to your preferences.

enter image description here

enter image description here

To apply your changes to the login and title screen, press "Apply system-wide".

enter image description here

share|improve this answer
add comment

Go to System Settings (either through Dash or Logout button on the Panel) and Choose Language Support. You can also just type Language Support into the Dash.

You can Install new languages there, prioritize them and apply them system-wide. Just log-out and back in to have changes take effect.

share|improve this answer
add comment

On Quantal (12.10), language selection is no more present at the LightDM prompt, there is only a selector for input, no more for session, you can choose to use another LightDM greeter, like lightdm-gtk-greeter. You need to install this package, change in /etc/lightdm/lightdm.conf this line from unity-greeter to lightdm-gtk-greeter:

greeter-session=lightdm-gtk-greeter

and in /etc/lightdm/lightdm-gtk-greeter.conf, this line from false to true:

show-language-selector=true

After that, language selection doesn't seems to work in quantal, but in really few rare cases I was not able to determine or reproduce.

I noticed than this is mainly a problem of coomunication between lightdm and AccountsService.

There is a bug report about this: https://bugs.launchpad.net/ubuntu/+source/lightdm/+bug/857651

You can change language by éditing the file:

/var/lib/AccountsService/users/<username>

For exemple in french:

Language=fr
FormatsLocale=fr_FR.UTF-8

Or in Mainland China chinese:

language=zh_CN
FormatsLocale=zh_CN.UTF-8
share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.