Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am trying to mount my Windows share through my Ubuntu box (no xwindow), but I continue to get

Unable to find suitable address

I have tried using the raw IP address, I have checked the credentials, I have disabled the Windows firewall, but I cannot find anything wrong.

benny@backup:~$ sudo mount -t cifs //my-desk/j -o username=me,password=s)mePasss /mnt/sync
Unable to find suitable address.
benny@backup:~$ ping my-desk
PING my-desk (10.10.10.43) 56(84) bytes of data.
♥
--- my-desk ping statistics ---
2 packets transmitted, 0 received, 100% packet loss, time 1008ms

benny@backup:~$ sudo mount -t cifs //10.10.10.43/j -o username=me,password=s)mePasss /mnt/sync
Unable to find suitable address.

Any help would be greatly appreciated!

share|improve this question

closed as too localized by Eliah Kagan, Eric Carvalho, jrg Jan 21 '13 at 2:12

This question is unlikely to help any future visitors; it is only relevant to a small geographic area, a specific moment in time, or an extraordinarily narrow situation that is not generally applicable to the worldwide audience of the internet. For help making this question more broadly applicable, visit the help center.If this question can be reworded to fit the rules in the help center, please edit the question.

    
I see the ping fails. Have you connection problems? –  enzotib Feb 28 '12 at 8:59
    
I don't understand why I would. I am connecting through SSH over the same network I'm trying to mount to. When I try ping now, I get "destination host unreachable", but it resolves the IP ok. –  Benny Mar 3 '12 at 15:29
    
This question appears to be abandoned and unanswered, if you are experiencing a similar issue please ask a new question with details pertaining to your problem. If you feel this question is not abandoned, please flag the question explaining that. –  Eliah Kagan Jan 21 '13 at 0:53
    
This is one of the top Google hits for that mount.cifs error message, so I'd like to point out that any connectivity issue that causes a TCP reset or ICMP unreachable message to be sent back to the source could result in it. In my case it was a firewall between the two hosts. –  Paul Gear Jan 28 at 6:09

1 Answer 1

You might have to explicitly specify the IP address, e.g.:

sudo mount -t cifs //my-disk/j -o "username=me,password=s)mePasss,ip=10.10.10.43" /mnt/sync
share|improve this answer
    
The OP "tried using the raw IP address." While that was presumably in the part that identifies the share (i.e., //raw-ip-address/j), it still seems unlikely that this would work if that does not. –  Eliah Kagan Jan 14 '13 at 0:08
1  
It does make a difference - if you specify the raw IP address in the UNC, then the client can't send a valid NetBIOS name to the server. Some servers will break if they don't get a valid NetBIOS name. –  jelmer May 3 '13 at 23:38
    
For sure, I had solved this issue with the additional ip= parameter –  zzeroo Aug 21 at 13:40

Not the answer you're looking for? Browse other questions tagged or ask your own question.