Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

This question already has an answer here:

I've installed DNScrypt proxy from https://github.com/opendns/dnscrypt-proxy/downloads and installed it under Ubuntu 11.10 x64. I started the proxy by

sudo /usr/sbin/dnscrypt-proxy --daemonize

syslog states

dnscrypt-proxy[2615]: dnscrypt-proxy is ready: proxying from [127.0.0.1] to [208.67.220.220]

I set the dns to localhost and restart the connection by gui. But the local dns can not be reached:

dnscrypt-proxy[2615]: dnscrypt-proxy is ready: proxying from [127.0.0.1] to [208.67.220.220]

netstat

PID/Program name
tcp        0      0 127.0.0.1:53            0.0.0.0:*               LISTEN          2231/dnscrypt-proxy

Someone has an idea? Thanks a lot!

share|improve this question
add comment

marked as duplicate by Mitch, Eric Carvalho, Kevin Bowen, Basharat Sial, user68186 May 8 '13 at 13:58

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

3 Answers

At least for Ubuntu 12.04 the issue is local DNS cache running on 127.0.0.1 (dnsmasq). Webupd8.org has a walk through and a script to change the local listening IP to 127.0.0.2.

http://www.webupd8.org/2012/02/encrypt-dns-traffic-in-linux-with.html

Scroll down to the Ubuntu section. I have it working for both 11.10 x64 and 12.04 x64 using their script. Initially it was not working on 11.10 but a full reboot resolved it.

share|improve this answer
add comment

Try setting the DNS servers to: 208.67.222.222, 208.67.220.220.

share|improve this answer
add comment

Try

sudo /usr/sbin/dnscrypt-proxy --daemonize --tcp-only

I think there is a bug in UDP connection to dnscrypt

More info

https://github.com/opendns/dnscrypt-proxy/issues/53

connection timeout after 60 seconds

share|improve this answer
add comment

Not the answer you're looking for? Browse other questions tagged or ask your own question.