Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

So I have samba setup and running on my Ubuntu box. I've successfully logged in on my WinXP machine, and was able to browse my home directories but an unable to create files, folders, etc. No write access.

In my samba config, I have set the this line read only = no, thus granting access to write to my home directories. Restarted samba in terminal using sudo restart smbd and no such luck.

Is there somewhere else I need to enable write access? I also added create mask = 0775 and directory mask = 0775 but I'm not too sure what that is doing.

Any suggestions?

EDIT I created a test share and was able to write to the share. My test share is /home/username/Pictures But when trying to write from the home directories, access denied.

share|improve this question
up vote 1 down vote accepted

Well it seems like the create mask = 0775 and directory mask = 0775 was causing the problem. I'm not familiar with the permissions and exactly what they do but I ended up fixing it by commenting out those lines.

share|improve this answer
this link may help: – Gerep Feb 28 '12 at 13:58

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.