Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Google shows this error referenced on some Thunderbird bug, but it's not clear to me how they resolve it.

Here is my issue:

I have vorbis file:

xdg-mime query filetype "my-file1.ogg"

→ output: x-vorbis+ogg

xdg-mime query filetype "my-file2.oga"

→ output: x-vorbis+ogg

I tried to add a key in gconf with gconftool-2 using above mime-type (x-vorbis+ogg) and I got this error:

`+' is an invalid character in key/directory names

If I ignore reported mime-type by xdg-mime and instead use simple mime-type for vorbis - ogg, then the key works only for files with extension ".oga" but not with more common extension ".ogg"

What to do? Is it possible to escape 'plus' sign in reported vorbis mime-type when passing to gconftool-2? Is this but in gconftool-2?

share|improve this question
have you tried "@ogg" – Ringtail Feb 27 '12 at 10:12
@htorque: It doesn't matter where, try to add key name with "+" anywhere it won't work. It seems like misfortune naming of mime-type here, although I don't know if maybe "+" can be escaped – zetah Feb 27 '12 at 10:14
@BlueXrider: yes – zetah Feb 27 '12 at 10:25
I'm trying to make handler in '/desktop/gnome/thumbnailers/audio@mime/' for vorbis files – zetah Feb 27 '12 at 10:44
up vote 1 down vote accepted

You have to replace characters like "/" and "+" with "@". This is working fine here on a freshly installed 11.04 VM:

  • Open the gconf-editor and go to /desktop/gnome/thumbnailers.
  • There should already be an entry for audio@x-vorbis@ogg.
  • Just paste the path to your thumbnailer for command, e.g.

    /home/YOUR_USER/bin/my-ogg-thumbnailer -s %s %u %o

    and set enable to true.

This will work for .ogg files, for .oga files do the same for the audio@ogg thumbnailer entry.

If you've messed up too much with thumbnailers and want a fresh start (will undo all thumbnailer customization):

rm -rf ~/.gconf/desktop/gnome/thumbnailers
gconftool-2 --recursive-unset /desktop/gnome/thumbnailers
share|improve this answer
Right! This works and rocks. Thanks :) – zetah Feb 27 '12 at 20:12

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.