Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Update: Loged in as guest and all works as charm. Using my account (administrator) nothing works and i am not able to locate advanced user management options :(

First of all - I use USB headset. there were some troubles with recognition at first, but prestigio were listed under hardware, so i activated it and all worked.

Now after I had to unplug headset and restart lappy, there is no sound devices at all listed under hardware tab. I cant adjust volume there. There is sound from built in speakers, but not from headset.

alsamixer shows me both built in audio card and prestigio (headset). I can choose them, but after esc and leaving alsa it rolls back to "default"

Following this thread, There are no Audio devices listed under hardware tab of audio preferences as a result no sound I gathered this info

Audio device: Intel Corporation 82801H (ICH8 Family) HD Audio Controller (rev 03)
    Subsystem: Acer Incorporated [ALI] Device 011e
    Flags: bus master, fast devsel, latency 0, IRQ 47
    Memory at 98400000 (64-bit, non-prefetchable) [size=16K]
    Capabilities: <access denied>
    Kernel driver in use: HDA Intel
    Kernel modules: snd-hda-intel

but solution offered (try killall pulseaudio; rm -r ~/.pulse* from terminal and logout or reboot) gave this result

pulseaudio: no process found
rm: remove write-protected regular file `/xxxxxx/.pulse/a336866c5ace61b2c9bc648a0000004f-runtime'? 
rm: cannot remove `/xxxxxxx/.pulse': Directory not empty

I am at lost now. Multiple restarts with headset on and off have not yielded any other results. Any suggestions? this is my first time using ubuntu and i am at best confident user in windows, so my own knowledge is quite lacking on issue...

update: aplay -l gives this as result.

**** List of PLAYBACK Hardware Devices ****
Failed to stat runtime directory /home/rizjaa/.pulse/a336866c5ace61b2c9bc648a0000004f-runtime: Invalid argument
card 0: Intel [HDA Intel], device 0: ALC268 Analog [ALC268 Analog]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: Prestigio [Prestigio], device 0: USB Audio [USB Audio]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
share|improve this question
    
try with sudo mv ~/.pulse ~/.pulse.old and restart your session. –  Takkat Feb 26 '12 at 22:22
    
mv: cannot stat `/home/rizjaa/.pulse': No such file or directory –  rizjaa Feb 27 '12 at 8:00
    
related: askubuntu.com/questions/224307/… –  Takkat Apr 8 '13 at 14:25

2 Answers 2

Either @Takkat suggestion worked or in mysterious ways something else worked, but after last restart all audio devices are back and working.

share|improve this answer
    
Sometimes a reboot miraculously cures things ;) –  Takkat Feb 27 '12 at 8:17

Takkat comment is the answer and solution:

sudo mv ~/.pulse ~/.pulse.old 

or just

sudo rm ~./pulse

work perfectly on 12.04 where I've exactly the same problem (audio devices was listed in every account except mine).

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.