Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Not much time after I installed my ubuntu, I installed ubuntu tweak and added shortcut keys for the applications I used most.

My Ubuntu tweak's shortcut management screen

However, I wanted to remove a shortcut key and was not able to (the last one). At least, I couldn't figure out a way to do that. I want to reconfigure them using ubuntu's keyboard tool, so I don't mind if I have to delete all shortcut keys from ubuntu tweak. Does anyone know how to do that?

share|improve this question
add comment

3 Answers

up vote 4 down vote accepted

enter image description here

Double-click the command to display the window shown.

Then press ESC i.e. the escape key and the key will be removed that is displayed as disabled

That just leaves the Command itself. Double click the Command to edit and type None. Press Enter and the Command will be removed.

share|improve this answer
    
Oh, it worked. But I still think that it should have a more explicit way to do it :) –  Luiz Rodrigo Feb 26 '12 at 21:25
    
suggest pop over to the authors launchpad account and ask just this question - hope this helps. answers.launchpad.net/ubuntu-tweak –  fossfreedom Feb 26 '12 at 21:31
    
Sorry but this way don't work in 12.04. When you press ESC key you get <Mod2>Escape –  piotrekkr Apr 30 '12 at 20:29
add comment

If using Escape doesn't work, follow most of the steps by fossfreedom but when you get to the part where you would press Escape, instead press Backspace and that should delete the command/key binding.

Keep in mind though, when you move to the keyboard shortcut system that Ubuntu provides by default, you will not be allowed to use the "Super" key in your shortcut...for some reason it is disabled there. You can apply it as a shortcut but the shortcut will never work unless used via Ubuntu Tweak or CCSM (Compiz).

share|improve this answer
add comment

The "Mod2" key that keep turn ON is actually the Num Lock key (...), as ridiculous as it may seems.

Turn Num Lock off, then press Backspace. The shortcut will (finally) be deleted. This also work on Ubuntu 12.04.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.