Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

My HTPC is running ubuntu 11.04 and I tried installing boxee a while back. I got it to install, but everytime I try to use apt-get now, it says:

$ sudo apt-get upgrade
Reading package lists... Done
Building dependency tree       
Reading state information... Done
You might want to run 'apt-get -f install' to correct these.
The following packages have unmet dependencies:
 boxee : Depends: libxmlrpc-c3 but it is not installable
E: Unmet dependencies. Try using -f.

If I run apt-get -f install it prompts me to uninstall Boxee. Now, Boxee is installed and very functional, I don't wish to uninstall it. How do I essentially make apt forget about Boxee and libxmlrpc-c3?

edit: the output of apt-cache policy boxee is:

$ apt-cache policy boxee
boxee:
  Installed: 0.9.22.13692
  Candidate: 0.9.22.13692
  Version table:
 *** 0.9.22.13692 0
        100 /var/lib/dpkg/status

edit: solution --

As suggested, I apt-get -f install'd, it removed boxee. I then re-installed and everything is working well.

share|improve this question
    
How did you install boxee exactly ? a ppa ? Try running sudo apt-get update && sudo apt-get upgrade –  bodhi.zazen Feb 26 '12 at 17:26
    
It has been a while since I installed it unfortunately. I had an older version installed perfectly fine, I then upgraded to a newer version and that's where I had dependency issues. I removed (or so I thought) the newer version and reverted back to an older one. I used dpkg to install the current version, but I'm not sure what I used for the newer version. –  smskelley Feb 26 '12 at 18:06
add comment

1 Answer

up vote 2 down vote accepted

boxee : Depends: libxmlrpc-c3 but it is not installable means that boxee's dependencies are not fully installed, so it may not work properly (note: I'm not saying that it won't work, just that some functions may not work).

To fix the problem, the easiest thing to do is to follow apt-get's advice and uninstall it. Uninstallation won't make you lose your configuration nor your files. Once apt-get -f install has finished, you will be able to install boxee again using:

apt-get update && apt-get install boxee

If this last command shows errors, then it'd be better to get in touch with the administrator of the archive from which you got boxee. The output of apt-cache policy boxee may be helpful.

share|improve this answer
    
To be honest, part of my apprehension stemmed from not knowing if I really needed to uninstall it. Knowing that I probably do gives me the courage to explain to my wife why I'm fiddling with the tv again. –  smskelley Feb 26 '12 at 18:07
    
I went through with it and uninstalled/reinstalled. With the issues I had with the newest version I was putting it off, but everything is fine now. Thanks :) –  smskelley Feb 26 '12 at 18:25
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.