Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Possible Duplicate:
How do I fix “malformed line” errors in sources.list?

For some reason upgrade and update are now broken in Ubuntu 10.04 LTS

~$ sudo apt-get update
E: Malformed line 5 in source list /etc/apt/sources.list.d/akirad.list (dist parse)
~$ sudo apt-get upgrade
E: Malformed line 5 in source list /etc/apt/sources.list.d/akirad.list (dist parse)
E: The list of sources could not be read.

Here is the file it says line 5 is screwed up in

## Akirad Repository for Ubuntu
## Please report any bug on akir4d at gmail.com

## ppa
deb http://ppa.launchpad.net/akirad/akirad/ubuntu  main #Akirad Repository - Main

deb http://ppa.launchpad.net/akirad/ppa/ubuntu  main #Akirad Repository - Main

#deb-src http://ppa.launchpad.net/akirad/akirad/ubuntu  main #Akirad Repository Sources- Main

#deb-src http://ppa.launchpad.net/akirad/ppa/ubuntu  main #Akirad Repository Sources- Main

What is wrong with the link deb http://ppa.launchpad.net/akirad/akirad/ubuntu main #Akirad Repository - Main in line 5?

share|improve this question

marked as duplicate by jokerdino, Ringtail, Mitch, Stephen Myall, Mik Oct 30 '12 at 15:32

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

1 Answer 1

up vote 2 down vote accepted

I do not use this repository. However your file is indeed wrong.

Comment your two deb lines and add this one (they will never work again so you are free to remove them afterwards) :

deb http://ppa.launchpad.net/akirad/akirad/ubuntu lucid main

your /etc/apt/sources.list.d/akirad.list should look like this :

## Akirad Repository for Ubuntu
## Please report any bug on akir4d at gmail.com

## ppa
deb http://ppa.launchpad.net/akirad/akirad/ubuntu lucid main #Akirad Repository - Main
#deb-src http://ppa.launchpad.net/akirad/akirad/ubuntu lucid main #Akirad Repository Sources- Main

Note the addition of "lucid" to the line.

For more information look at the ppa launchpad page :

https://launchpad.net/~akirad/+archive/akirad?field.series_filter=lucid and click on "Technical details about this PPA"

In case another ppa is making you trouble go directly to it's launchpad webpage for more info.

Best Regards.

share|improve this answer
    
Thanks Antoine. It works now. –  max Feb 26 '12 at 19:06
    
you're welcome ;) –  Antoine Rodriguez Mar 3 '12 at 21:53

Not the answer you're looking for? Browse other questions tagged or ask your own question.