Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

i noticed that some of my apps are in the background in unity-panel.
the apps are vmware-workstation,jupiter, empathy
this is what i meanenter image description here

as you can see on the left some of my apps are running but in the background
if i didn't set my unity-panel to see-through i wouldn't have noticed it.
if i restart my laptop and start empathy it doesn't go in the background and also when
i run compiz --replace the apps are back in the foreground this happens a lot when i am working my apps are suddenly in the unity-panel background?

share|improve this question
    
Didnt got your question :( –  Tachyons Feb 26 '12 at 13:58
    
how to fix that (apps in the unity-panel background i find it really annoying, i have to taskkill some apps cause when i run it again i get "another instant is already running" err box –  blade19899 Feb 26 '12 at 14:07
    
Disable these apps from startup applications list –  Tachyons Feb 26 '12 at 14:26
    
they are not running from startup, i start them after Ubuntu booted up –  blade19899 Feb 26 '12 at 21:41
add comment

2 Answers

Run this in a Terminal window (Ctrl+Alt+T):

gsettings set com.canonical.Unity.Panel systray-whitelist "['all']"
share|improve this answer
add comment

Well, I copied it from a tutorial on getting VMWare workstation to show up in the panel, but Im guessing Unity has some sort of whitelist blacklist to determine what shows up in the panel, probably to keep a consistent look and feel. After running that command, Chrome and Google Talk showed up as well. I seriously just copied it from another post, and remembered this post and thought it would be helpful.

http://www.gmjjavadesigns.com/content/installing-jungledisk-desktop-ubuntu-1110

share|improve this answer
    
Welcome to AskUbuntu! Whilst this may theoretically answer the question, it would be preferable to include the essential parts of the answer here, and provide the link for reference. –  Oyibo Nov 7 '12 at 7:43
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.