Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Unfortunately i disable gnome-shell web search option with the following command

gsettings set org.gnome.shell disabled-open-search-providers "['google.xml', 'wikipedia.xml']"

How to re-enable it?

Also how can i change the default search. Default gnome-shell search in wikipedia. I need to search in google by default.

thanks in advance

share|improve this question
    
This doesn't work to me!! I tried [code] gsettings set org.gnome.shell disabled-open-search-providers "[]" [code] but nothing! They're still out! I did the same wrong of the first asker, but i'm not able to solve it! thanks federico –  fede.cazzaro Apr 24 at 11:13

1 Answer 1

up vote 2 down vote accepted

For the first problem you should simply open dconf-editor (maybe you should install it first), then go to org>gnome>shell and void the disabled-open-search-providers' string.

Otherwise, you can simply do in a terminal

gsettings set org.gnome.shell disabled-open-search-providers "[]"

For the second problem, there's already an answer (follow the links at the end of the answer to that question): Is it possible to customise the search engine buttons in GNOME Shell?

share|improve this answer
    
Alternatively, you could just click the "Set to Default" button on the bottom right of the dconf-editor's window. –  Sparhawk Sep 24 '12 at 1:32

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.