Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

So I'm trying to update my sound card driver but I need to compile first.

After entering the sudo make command, I run into errors, missing files, etc.

See link. Terminal_Lines

I've installed the build-essentials with the following command:

sudo apt-get install linux-headers-$(uname -r) build-essential

Apparently I'm missing something but don't know what. Suggestions?

share|improve this question
add comment

2 Answers

up vote 3 down vote accepted

A few things to note:

  1. It seems you are tryimg to install a driver last updated in 2008, which would be written for Linux kernel version 2.6 on a Linux 3.0 system. This will very likely not work.
  2. Practically all source tarballs you download have a configure script you should run befire running make, was there one and did you?
  3. Some googling tells me that the card is supported in ALSA, so compiling and installing manually should not be needed.
  4. If you have working, but bad sound, some people seem to be happier after switching to OSS4 and doing away with PulseAudio.
share|improve this answer
    
Would upgrading the sound card do the trick? It's an older box, say 2006ish. –  Muhnamana Feb 26 '12 at 14:12
    
I have working sound only coming out of the rear speakers, which in itself seems strange. –  Muhnamana Feb 26 '12 at 14:12
add comment

Shot in the dark, but if you created the 'Sound' directory, try to rename it to 'sound'. I could be way off here because I don't know anything about the package you're trying to build/install. My second guess would be that you may need some of the *-dev variants of some packages, which often have the header files needed to build against.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.