Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am trying to download kcachegrind after a reinstallation of my OS. But I keep getting "dependency" failures. I have tried going through the Ubuntu software manager (which worked perfectly before...) and Synaptic. With synaptic, I got specific package failures and when I searched for the packages I got more package dependencies. After the 5th time of this I gave up because there must be something else going on.

Please help?

share|improve this question

1 Answer 1

up vote 1 down vote accepted

Open a terminal and try this:

sudo apt-get update

sudo apt-get clean

sudo apt-get autoremove

sudo apt-get update && sudo apt-get upgrade

sudo dpkg --configure -a

sudo apt-get install -f
share|improve this answer
1  
Hey! That worked! Can you please explain what you did? –  ad3l1n3 Feb 26 '12 at 23:41
    
Thank you by the way. :) –  ad3l1n3 Feb 26 '12 at 23:41

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.