Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have an old system with NVIDIA Corporation NV25 [GeForce4 Ti 4600]. When running Ubuntu , the nouveau driver loads fine but does not log into Unity with compiz. Instead it logs into Unity-2D. Any idea how to enable 3D/ compiz with the nouveau driver.

OS: Ubuntu 12.04 Beta2

The nvidia driver is no more available for this graphics card, so have to rely on nouveau.

UPDATE: Bug reported on launchpad . See here.

There has been no reply as yet to this bug-report - does anyone have any idea how to resolve this?

Further information,

Also, if I use kubuntu desktop, kwin graphics works just fine. But, the users prefer Unity over KDE so I have uninstalled Kubuntu.

installing libgl1-mesa-dri-experimental does not have any effect on the installation. still booting to unity-2d

/usr/lib/nux/unity_support_test -p

OpenGL vendor string: Nouveau OpenGL 
renderer string: Mesa DRI nv25 x86/MMX/SSE2 
OpenGL version string: 1.2 Mesa 8.0.2 
Not software rendered: yes 
Not blacklisted: yes 
GLX fbconfig: yes 
GLX texture from pixmap: yes 
GL npot or rect textures: yes 
GL vertex program: no 
GL fragment program: no 
GL vertex buffer object: yes 
GL framebuffer object: yes 
GL version is 1.4+: no 
Unity 3D supported: no 
share|improve this question
    
If kwin and gnome-shell work, I am assuming Unity effects should work as well. I will get the results for you asap. –  Ubuntuser Apr 2 '12 at 11:38
add comment

2 Answers 2

up vote 2 down vote accepted

This all correct. Your card is based on the Nvidia NV20 chipset which has no 3D support using the Nouveau drivers.

enter image description here

Most of it is WIP and not totally working or so patchy that cannot be considered able to run Unity3D.

For full support of your graphics card you need to install the Nvidia 96.43 drivers (those are the most recent ones your card supports). If you haven't installed any drivers in you system until now just open a terminal and use the following commands

sudo apt-get update && sudo apt-get upgrade
sudo apt-get install nvidia-96

Reboot and you should be using the Nvidia driver you just installed. To make sure run sudo lshw -C display and look for the driver in use at the configuration: driver= line.

share|improve this answer
    
+1 Bruno - good website to note in the future. –  fossfreedom Apr 2 '12 at 15:39
    
Thanks Bruno, so, that means only compiz requires 3D? Gnome Shell and KWin does not? –  Ubuntuser Apr 2 '12 at 15:51
    
@Ubuntuser Since its WIP I can assume that some of the 3D implementation is done but not enough to pass the test Unity does at login. The bug report is the way to go since kwin is running (apparently, we have to trust you on this and the bug triage will sort that out no i'm not saying I don't trust you). Compiz is always weirds but I am sure it will not be the only 3D software that you will fail to run. I am looking for an alternative driver for you and will add it to the answer as soon a I do. –  Bruno Pereira Apr 2 '12 at 15:54
    
@BrunoPereira: Thanks a ton! Eagerly waiting! –  Ubuntuser Apr 2 '12 at 16:02
    
96.43 is the latest driver for your card, install instruction added to answer. –  Bruno Pereira Apr 2 '12 at 18:47
show 1 more comment

The libgl1-mesa-dri-experimental was created to enable 3D Graphics for certain types of Nvidia cards.

Whilst you said that you have installed this package, its worth double checking the Additional Drivers window.

This experimental driver should be visible and you could try Activating the driver.

Reboot and try logging into Unity 3D.

If this still doesnt work, then you could try forcing the start of Unity 3D.

sudo nano /etc/environment

add: UNITY_FORCE_START=1

Save and reboot

If this still doesnt work then I'm afraid you are likely to be out of luck.

Your graphics card has legacy support from the NVIDIA v96 proprietary driver. However this driver from NVIDIA will not support Unity 3D (the latest mesa in Precise does not support 3D extensions from this driver).

If you have a stable system I would stick to the nouveau driver and thus Unity-2D/Gnome-Classic

share|improve this answer
    
thanks . i will try to make the changes and report. –  Ubuntuser Apr 3 '12 at 11:11
    
if i add UNITY_FORCE_START=1, it logs in to a blank screen with the wallpaper only. Cannot see any panels and launcher and the screen becomes unresponsive. –  Ubuntuser Apr 6 '12 at 21:06
    
that's a real shame - basically this means that your nvidia card is too old to support unity 3d :( –  fossfreedom Apr 6 '12 at 21:07
    
i am still waiting for the bug report to be updated by canonical, as they are expecting a new update for the nvidia-96 –  Ubuntuser Apr 7 '12 at 12:09
    
also added a new bug report bugs.launchpad.net/ubuntu/+source/xserver-xorg-video-nouveau/… –  Ubuntuser Apr 7 '12 at 12:09
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.