Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am personalising my Gnome-Shell in Ubuntu 11.10

I would like to disable the feature to open the Gnome's Dashboard when I close the last Window in a Workspace.

Edit to clarify: The dashboard is available only in GNOME Shell. The dashboard opens if you press the windows key (aka SUPER) or if you move the mouse to the upper left corner. If you close the last window of a workspace, but there are open windows on other workspaces, the dashboard opens automatically. The latter behaviour is annoying if you do not want to use the dashboard to open new windows or to change workspace. There are many ways to to both (Gnome do, Docky, keyboard shortcuts, clicking on something on the desktop, ...).

Edit: There is a related Q&A, which was closed because the asked the same question for Mint: How can I prevent the activity view for opening when I close the last running app?

share|improve this question
    
Did you try Dconf-editor? Gnome uses dconf to store its configuration parameters. sudo apt-get install dconf-tools Once it is installed, press Alt + F2 and type: dconf-editor and check for org-->gnome-->shell(may be). I use natty so can not try. I'll try install in VBox. –  virpara May 28 '12 at 4:15
    
Can you explain exactly what's happening, and possibly include a screenshot or something? I'm not seeing this in Gnome or Gnome Classic with 11.10.... –  izx May 31 '12 at 7:24
    
@virpara A good suggestion! Unfortunately I couldn't find anything. But I couldn't find any good documentation and the dconf-editor does not provide a search function. So maybe there is something I missed... –  lumbric May 31 '12 at 17:47
    
@izx I added a clarification (currently under peer review), probably you won't see the behaviour. –  lumbric May 31 '12 at 17:55
add comment

1 Answer 1

I just stumbled upon this (closed) question at stackoverflow (see also this Q&A). The information there enabled me to solve the question - 22 hours before my own bounty ends... :)

Note that this is an ugly solution, because you have change 2 lines in the sources of GNOME shell. It would be better to convert it to an (easy usable) extension. The information given here might lay the basis for an extension, but I don't know exactly how to do this in an extension.

Basically you have to uncomment the command overview.show() in the file /usr/share/gnome-shell/js/ui/main.js (and the if before). It might be a good idea to make a backup of the file before.

$ diff main.js main.js-old
350,351c350,351
<         //if (!overview.visible && showOverview)
<         //    overview.show();
---
>         if (!overview.visible && showOverview)
>             overview.show();

To apply the changes run:

sudo glib-compile-schemas /usr/share/glib-2.0/schemas/

The lines before confirm my suspicion that there is currently no option to change this behaviour.

share|improve this answer
    
Accept your answer and award yourself the bounty! –  izx Jun 1 '12 at 4:48
    
I can't accept answers, it is not my question. And it seems as if it is not possible to award yourself for your own bounty. Nevermind... –  lumbric Jun 1 '12 at 17:37
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.