Sign up ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free.

I switched from Win7 to Ubuntu and found that my laptop is getting too hot. (very hot). When I was using Win7, it was very nice, cool.

Why this is happening and how do I fix it.


Lenovo G570; Ubuntu 11.10 32-bit

share|improve this question
possible duplicate: – maniat1k Feb 25 '12 at 16:25
I changed the window manager for something lighter and more efficient like e17 or xfce, it works pretty nice on my old eeepc. You can install another window manager and choose the one you want to use before loging in. – 3nrique0 Mar 6 '13 at 13:22

5 Answers 5

up vote 1 down vote accepted

There are several issues with overheating in 11.10. At least most of those are fixed in Precise (which will become 12.04). I had similar issues with all my computers on 11.10, but never since. (Never before 11.10 either).

If you really want to get into it, you can try upgrading your kernel. Or maybe you'll rather want to upgrade to 12.04 Beta 1 on the first of March. Of course, you could always download it now and try it in a memory stick or something, just to confirm that all the issues have been resolved. They should.

share|improve this answer
Upgrading kernel.. well, how could I do that. I think my current kernel is v3 (not sure). To what version should I upgrade and how stable it is on other functionality – Surya Feb 25 '12 at 18:03
As upgrading kernel is very big deal, will that clearly fix this error ?? – Surya Feb 25 '12 at 18:10
Upgrading the kernel isn't such a big deal, since there's no dependencies to worry about. But I would probably suggest just waiting a little while and upgrading to 12.04. It should fix it. This has never been an issue with Ubuntu before 11.10, and I haven't heard anyone complaining about it in Precise. 11.10 was a very special version in many ways. There were extremely large system changes in that version. – Jo-Erlend Schinstad Feb 26 '12 at 15:29

Assuming you have an Intel based system like my Lenovo X220 you could try appending i915.i915_enable_rc6=1 to your boot command line, which works for me. YMMV

share|improve this answer
I even use Intel; its 2nd Gen i5; However, I thought to use Win7 until its fixed .. – Surya Apr 21 '12 at 13:42

Try dimming the screen brightness. I have an Acer laptop that will get hot if I try running more than email and a browser. Tried everything written about temp problems except a bios update. Last night I dimmed my screen brightness down to 60%, was able to burn DVD, watch full screen video, email and browser, and download a torrent. Laptop was warm, but did not get hot. Full screen video would do it in less than 5 minutes before.

share|improve this answer

I had same problem on my HP ProBook4530s (I have i5 and ATI Radeon graphic card). You should try activate "ATI/ADM proprietary FGLRX graphics driver" (post-release updates in my case).

System Settings -> Additional Drivers

share|improve this answer

Just might be because your laptop hasn't undergone a complete service. Just go to any laptop repair shop and give your laptop a good service... heat sync. fan gets out of order because of the garbage stuck inside the ventilator, resultantly it doesn't let the heat out of the laptop... So try this solution and enjoy...

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.