Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have installed Ubuntu 11.10 on my lenovo laptop and found a "chip" image on the top of the screen. It showed me to install 3 drivers

  1. ATI/AMD Proprietary FGLRX graphics drivers (post-release updates)
  2. Broadcom STA wireless drivers
  3. ATI/AMD Proprietary FGLRX graphics drivers

When I installed 1st one, it showed me some error so, I installed 2nd one it was successful. I went to 3rd and it failed 1st time and later it worked.. After when I came back and found that it isn't not installed.

I think these are for my ATI Radeon graphic drivers but don't know why its happening. If even found the "System Info" isn't showing any information about graphics.

So, how do I know whether my graphics are installed or not and if not how do I?

share|improve this question
    
For the record, the second driver is for your wireless network adapter and has nothing to do with your graphics card. –  bessman Feb 25 '12 at 16:58
    
The error messages are important. They give clues as to the problem. without them people cannot answer but can only guess. When you log in do you have two options - Ubuntu and Ubuntu 2D? If you have the Ubuntu option then your proprietary graphic driver is activated. In the past the Additional Driver utility would say: "Activated but not in use." That is a false message. If you have that message ignore it. –  grahammechanical Feb 25 '12 at 17:46
add comment

2 Answers 2

up vote 3 down vote accepted

Try running fgl_glxgears. If the driver is correctly installed, you should see an animation of a cube looking like this:

fgl_gears

If you get an error, that means the driver is either incorrectly installed, or not installed at all. In order to install it, follow these instructions.

share|improve this answer
    
nope, its showing error. –  Surya Feb 25 '12 at 16:13
    
In that case, follow the instructions in the link above. I have recently installed these drivers myself by following said instructions, so I can vouch for their excellency. Also, what's the error? –  bessman Feb 25 '12 at 16:19
    
I forgot to copy that.. All I could understand from it is that, it couldn't recognize :( –  Surya Feb 25 '12 at 18:07
    
I will add a comment as soon as I install those drivers as mentioned in the instructions –  Surya Feb 25 '12 at 18:08
    
@Carborundum cool tip about the cube. –  bioShark Mar 13 '12 at 23:22
add comment

Just want to add the Terminal command:

lsmod

to the conversation, to show what kernel modules are installed.

lsmod | grep video

specifically for video module.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.